Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • Provision Config/Secrets to XenStore from XO

    2
    0 Votes
    2 Posts
    439 Views
    olivierlambertO
    Hi, Indeed, only root user in the guest can read it Any user that can see the XAPI object will be able to read it So I would say it's "reasonably safe", but it all depends on your global usage context and level of confidentiality you need.
  • XO User restore VM from Backup

    2
    0 Votes
    2 Posts
    510 Views
    olivierlambertO
    Hi! Short answer: no. Restore is only for a "superuser" (admin) not for "regular" users. In the long run: maybe So it's up to you (for now) to restore the VM.
  • 0 Votes
    20 Posts
    4k Views
    florentF
    @AlexTheBest great work and effort alex , and welcome to modern storage .
  • Coalesce failed, skipping - corrupted

    6
    0 Votes
    6 Posts
    2k Views
    G
    @olivierlambert so I went to restore this VM from backup, and noticed that the monthly backup is currently running on this VM as we speak. Will restoring from this newest backup fix my issue? Or does it restore the issue back into production?
  • This topic is deleted!

    0
    0 Votes
    0 Posts
    33 Views
    No one has replied
  • XOA source update

    Solved
    3
    0 Votes
    3 Posts
    908 Views
    R
    works. thanks!
  • 0 Votes
    1 Posts
    622 Views
    No one has replied
  • Recover a local drive used for a SR

    1
    1 Votes
    1 Posts
    2k Views
    No one has replied
  • Ubuntu Jammy Jellyfish 22.04.2 LTS Super Slow Console

    Solved
    4
    0 Votes
    4 Posts
    2k Views
    planedropP
    @Andrew This was the answer, thank you! I had it set with 8MiB of video memory which was fine with an older install but 22.04 needs more it looks like. Bumped that up to 16 MiB and it's super smooth now. Thanks for your help! @olivierlambert increasing the video memory was the solution. But to answer your question this was in BIOS mode rather than UEFI.
  • Increasing the disk size of vmguest without shuting down

    10
    0 Votes
    10 Posts
    6k Views
    olivierlambertO
    @MathieuRA Indeed, that's the right way to do it, I think
  • [Guide] Recovering from CR with error - no space for coalesce

    4
    7
    0 Votes
    4 Posts
    1k Views
    olivierlambertO
    Hopefully, we'll make things more obvious in terms of "danger zone" in XO 6 UI
  • XO Backup - question on file level restore

    backup file-level lvm
    12
    1
    0 Votes
    12 Posts
    4k Views
    S
    I have opened a ticket to support because file level restore doesn't work anymore after latest update. Best regards Walter
  • Change Email Address for XO Report

    2
    0 Votes
    2 Posts
    802 Views
    DanpD
    Look under the configuration for the backup-reports plugin, which can be found under Settings > Plugins.
  • how configure aws s3 bucket for xen orchestra remote s3 beta

    9
    0 Votes
    9 Posts
    2k Views
    ontzuevanhussenO
    @kamal8641 AWS S3 remote on xen orchestra works fine in my tests.
  • Can't copy or move VM from host with xen 6.5 to host xcp-ng 8.2

    13
    0 Votes
    13 Posts
    3k Views
    L
    thanks for all advices just moved all services to new vm, that makes topic is closed. for last try i updated xen 6.5 to 7.4 but problem remains
  • How to grant permission to User/ACL to download snapshots of VMs

    3
    0 Votes
    3 Posts
    867 Views
    L
    @olivierlambert Hahaha you got it! Thank you
  • Ubuntu 22 Cloud Init/Config Network & Partition Assistance

    11
    0 Votes
    11 Posts
    15k Views
    L
    Hi there Gsrfan Apologies for the delayed response, I had to shelf this passion project to focus on other work So far managed to get the host, static IP, packages, users & their keys/password etc sorted with the init I was working last on lvm partitions, to grow them and that ended up a bit of a mess I might return to this at a later stage but I found your help and advice invaluable to getting the config to where it is now Thank you so much
  • file restore on large backups ends in print_req_error: I/O error's

    8
    0 Votes
    8 Posts
    2k Views
    T
    @olivierlambert said in file restore on large backups ends in print_req_error: I/O error's: Yes, that sounds the next step to do Something is wrong during the mount phase. Also check you have enough RAM in your XOA. Ok, filesystem checks out - as far as I can see having: Done full restore of VM from the same Delta image. Booted VM, logged in and done 'tar cvf /dev/null *' of the filesystem I'm trying to restore from - which ran to completion without error. I upped the RAM for XOA from default 2GiB to 16GiB and re-tried - and same result. I can try yet more RAM if needs be but would hope 16GiB is more than enough? The console error on XOA is more detailed than my install- so don't know if this helps: blk_update_request: I/O error, dev loop0, sector 8912912 op 0x00:(READ) flags 0x80700 phys_seg 1 prio class 0 Looks to be the same issue, just reported differently. You also (on both systems) get kernel chatter about "tasked blocked" (understandable, as it is).
  • Can't restore VM's from 'read-only' remote?

    3
    0 Votes
    3 Posts
    790 Views
    T
    @olivierlambert said in Can't restore VM's from 'read-only' remote?: A remote (now Backup repository) is meant to write backups into it. If you aren't able to write, then, sure, you can restore but you won't be able to backup anything. Yes, understand that - I'll have to re-test here, but I'm sure when it was 'read-only' - I couldn't restore anything from it, as nothing showed up in XO's "Backup / Restore' list of backups... The remote was mounted on two systems - hence why made R/O for one of them (this was just for testing restores).
  • 0 Votes
    2 Posts
    3k Views
    B
    @Zevgeny Did you succeed to remove the protection with "xe vm-param-clear"? It didn't worked perfectly for me. Before I use xe vm-param-clear, I have the following: [18:28 xcpng02 ~]# xe vm-param-list uuid=37b7a201-eb45-b7de-5ce4-da25b1c7b547 | grep block blocked-operations (MRW): pause: true; hard_shutdown: true; (unknown operation): true; hard_reboot: true; clean_shutdown: true; suspend: true; clean_reboot: true [18:28 xcpng02 ~]# Now I try to clean: [18:28 xcpng02 ~]# xe vm-param-clear uuid=37b7a201-eb45-b7de-5ce4-da25b1c7b547 param-name=blocked-operations The value given is invalid field: blocked_operation value: (unknown operation) [18:28 xcpng02 ~]# After, "blocked-operations" looks like this: [18:28 xcpng02 ~]# xe vm-param-list uuid=37b7a201-eb45-b7de-5ce4-da25b1c7b547 | grep block blocked-operations (MRW): (unknown operation): true; hard_reboot: true; clean_shutdown: true; suspend: true; clean_reboot: true [18:30 xcpng02 ~]# In the GUI of XOA, the "Protect from accidental shutdown" is removed but not on the command line.