Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • Memory usage is not showing up in XOA

    Solved
    12
    1
    0 Votes
    12 Posts
    3k Views
    S
    @olivierlambert That did the trick. Wanted to make sure to say thanks for your help. Thanks again! Hope you have a great day!
  • XO rebooted, remotes lost, unable to add back

    16
    0 Votes
    16 Posts
    4k Views
    olivierlambertO
    So what you need is more something like backup tiering (or secondary backup). This feature is currently a work in progress by @florent
  • Continuous Replication backup (Missing Job)

    2
    0 Votes
    2 Posts
    494 Views
    olivierlambertO
    It means one VM got a backup job that's not in your current XO. Are you sure you restored your previous XO config?
  • Smart reboot. Is that going to be implemented?

    5
    0 Votes
    5 Posts
    1k Views
    J
    @olivierlambert ok. For info: xo-server 5.113.0 / xo-web 5.116.1 Installed this version XO yesterday and tried a smart reboot with 14 vm's running. Windows and linux vm's. Of which some linux vm's have NFS shares which I use for ISO files and making backups with XO. These I normally have to disconnect before I can do a reboot of the host otherwise it will not reboot and had expected that this would not be necessary now. It took a very long time for all vm's to enter suspend mode (>2 hours) and the server did not reboot. Probably ran into not shutting down the NFS shares. I finish much faster if I manually shut down all vm's (and disconnect the NFS shares) reboot the host and restart the vm's. But maybe I am overlooking something then I would like to hear about it.
  • How to fix XOSTOR

    11
    0 Votes
    11 Posts
    3k Views
    F
    @brodiecyber I can see it exist in /opt/xensource/bin/linstor-kv-tool but no idea on how to use it
  • Can't import ISO through OVA--not a supported filetype?

    4
    0 Votes
    4 Posts
    1k Views
    MathieuRAM
    @miker Hi Thank you for your feedback. We will explore ways to enhance the current UI.
  • Xen Orchestra Update Failed - Error: ENOSPC: no space left on device

    9
    0 Votes
    9 Posts
    4k Views
    DanpD
    You may need to extend the partition first using growpart.
  • 0 Votes
    7 Posts
    2k Views
    olivierlambertO
    Okay so you are right: we did not test this scenario, so that's why the error is cryptic. I'm adding @Enishowk in the loop so he can put that in our backlog
  • Why do I see this message?

    4
    0 Votes
    4 Posts
    2k Views
    planedropP
    If I'm being honest here I don't really find the messages as annoying as you are making them out to be. Sure if I had a choice I would want them gone, but it's really not a big deal, 1-2 clicks and they are gone until the next time I login. I also kinda like the reminder on the sidebar about no support, helps me remember that A. I'm in my lab environment and B. I'm using a from the sources version so I need to manually do updates etc.....
  • Slow backups (updated XO source issue)

    17
    0 Votes
    17 Posts
    5k Views
    A
    @julien-f Thanks. I updated to 0444cf0 and CR times are normal again (as expected).
  • cannot mount NFS remote

    solved
    2
    0 Votes
    2 Posts
    2k Views
    D
    OK I got it. I didn't think that the host was using apparmor, but it actually does. So it must be started using --cap-add sys_admin --security-opt apparmor:unconfined Now it works.
  • xo-cli --register produces "invalid parameters" errors in xo logs

    Solved
    18
    0 Votes
    18 Posts
    4k Views
    M
    @julien-f OK, server upgrade it is. Thanks for a prompt reply. Appreciate it.
  • Migrate to new server and backups

    6
    0 Votes
    6 Posts
    1k Views
    DanpD
    Ok. You threw me a curve ball when you mentioned the "[XO Backup blah blah]" stuff. I think you are referring to the snapshots. If so, then yes they get transferred over when you migrate the VMs.
  • NFS for ISO and VDI doesn't recognize subdirectory path

    8
    2
    0 Votes
    8 Posts
    2k Views
    gskgerG
    @Darkbeldin Mh, in the SMlog it is ls /tmp/nfs -1 --color=never. Thats the number one but should that be the letter l? With the number one, lsreturns. [17:31 h01 ~]# ls /tmp/nfs -1 --color=never test textfile
  • Backup Error with sufficient Space

    xenorchestra backup hdd
    7
    2
    0 Votes
    7 Posts
    3k Views
    DarkbeldinD
    @felipefonsecabh You need to check the specific checkbox: https://xen-orchestra.com/docs/full_backups.html#backup-without-snapshot
  • S3 Backup "Please Match The Requested Format"

    38
    1
    0 Votes
    38 Posts
    17k Views
    V
    Assuming I have the setting in the correct place, I'm not seeing any significant difference whether the setting is there or not. without setting Duration: 10 minutes Size: 41.71 GiB Speed: 72.5 MiB/s with setting Duration: 10 minutes Size: 41.71 GiB Speed: 72.87 MiB/s CPU usage appears to be about the same.
  • pool disappear after VM migration

    10
    0 Votes
    10 Posts
    2k Views
    DarkbeldinD
    @Momtez-Medini Please open a support ticket even without subscription we will help you there.
  • 10 gig secondary network

    6
    0 Votes
    6 Posts
    2k Views
    fohdeeshaF
    @abelaguilar indeed you do not have to fill out the dns and gateway fields - in fact as you surmised you shouldn't. Where you getting an error or something when leaving them blank? The only mandatory fields are IP and netmask.
  • This topic is deleted!

    Unsolved
    1
    0 Votes
    1 Posts
    3 Views
    No one has replied
  • 0 Votes
    5 Posts
    921 Views
    Daikon-RadishD
    So it looks like the warm migration of the first VM I tried migrating works, but after trying to migrate another VM, I'm getting a new error message: "Warm migration: task has already ended" Is there any particular process that I'm missing to mark the first VM as successfully migrated? **edit: Maybe I'm just impatient because after waiting another couple of minutes it looks like it's migrating OK.. LOL