Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • New and exciting backup errors

    7
    0 Votes
    7 Posts
    2k Views
    A
    @andrewreid Not that this helps with your error, but my nightly S3 delta backups to Wasabi have been working just fine. I'm using XO source and keep mostly up to date with master. S3 and NFS are different backup formats so NFS working does not mean S3 will work. Sometimes Wasabi causes failures but not recently and not that last more than a few VMs in one night. The next backup run (manual restart or next nightly) seems to work correctly. I force a full backup every 3 months just to make sure I have a good checkpoint in case undetected corruption creeps into the delta data. Plus I have replication and other backups. I did have a problem once (not exactly yours) with a VM and just deleted the S3 backup data which forced a full backup again. Sucks because you don't have the weeks of deltas anymore. Error #3 (date-time) is strange. May be a backblaze issue. You could create a new S3 remote to backblaze (new bucket or directory) and test one failing VM backup to the new remote and see if it works (and works again for delta). You could set the retention low to test merge too. I have a setup like this with a local MinIO server for S3 testing and local backups.
  • Backups not starting after failed NFS mount

    4
    0 Votes
    4 Posts
    900 Views
    olivierlambertO
    haha that's exactly the purpose of the remote test button No grand mastery, just experience
  • Moving backups to another remote?

    3
    0 Votes
    3 Posts
    1k Views
    K
    @olivierlambert I want to move them on NFS in order to be able to backup later from NFS to S3 in more granular way Generally, we are talking about XO - NFS. S3 would be out of XO.
  • Register instance of XO Running on Hyper-V

    4
    0 Votes
    4 Posts
    1k Views
    julien-fJ
    @someone2b Just install this work-around xenstore-read with the following commands and hopefully it will work. sudo -s cd /usr/local/bin curl -O https://gist.githubusercontent.com/julien-f/a6f98de3bd5a775f3f04b2fa14a9a102/raw/xenstore-read chmod +x xenstore-read
  • Second Pool Host Network 0 doesn't work for VMs

    1
    0 Votes
    1 Posts
    551 Views
    No one has replied
  • XOA not reachable after reboot

    2
    0 Votes
    2 Posts
    527 Views
    olivierlambertO
    Hi, This is documented. https://xen-orchestra.com/docs/xoa.html#first-console-connection
  • XCP-ng logs in XOA - where to find

    3
    0 Votes
    3 Posts
    2k Views
    K
    Just if somebody else is searching for the same thing, although it is not directly related to XOA: If you want to get these alerts by mail and you are not using XCP-ng-Center, you can activate them with: xe pool-param-set uuid=pool-uuid other-config:mail-destination=mail@example.com xe pool-param-set uuid=pool-uuid other-config:ssmtp-mailhub=mailserverip:port KPS
  • Create VM Error SR_BACKEND_FAILURE_1200, No such Tapdisk.

    16
    0 Votes
    16 Posts
    6k Views
    ronan-aR
    @geoffbland No problem. It's the first time I see this error with tapdisk (and it's it's even more surprising to have it on this type of SR...). It had all been working fine and I had not changed anything on the share - it just stopped working In this case, maybe there was a problem with the XAPI, a lock on the device or something else. Not easy to find the cause without remote access. Don't hesitate to ping us if this problem comes back.
  • Migrating large disk - any risks?

    6
    0 Votes
    6 Posts
    2k Views
    olivierlambertO
    It's more a less that. In short, the new disk is created on both sides, and blocks mirrored on both sides. First, the read only "parent" VDI with frozen blocks is copied, when it's done, the VM is briefly paused, the memory migrated to the destination and then unpaused on destination. Consequently, only the blocks written during 11 hours will use space for new blocks on the source SR (and destination, since it's mirrored).
  • All imports fail with error

    6
    0 Votes
    6 Posts
    2k Views
    julien-fJ
    @sbz71 The stable channel should not have the issue, not sure when we'll release a fix for latest. If you have an XO subscription, you can open a support ticket and a support tunnel and we'll be able to patch your install My bad, I misunderstood the question
  • Broken backup logs

    bugs planned
    18
    0 Votes
    18 Posts
    5k Views
    A
    @julien-f Thanks. I'll post an update if I hit the problem again.
  • Generic Error When Running S3 Backups to Minio on Latest XO Build

    2
    0 Votes
    2 Posts
    848 Views
    A
    @creoleMalady This does not help you, but my setup works with MinIO S3 (current version minio_20220607003341.0.0_amd64.deb) and current XO commit a5e9f. I'm running XO commit 379e4 (June 2nd) and it has been working correctly with Wasabi. I updated XO to commit a5e9f (current master) on a second server and backup still works for me to MinIO.... Delta Backup as a full and as a delta with and without merge.
  • Install new supplemental pack not work

    7
    0 Votes
    7 Posts
    2k Views
    R
    @olivierlambert last update> I try diferent browser(Firefox) and ISO localy > all working First time I try from Chrome and ISO on remote drive
  • Is it possible to migrate from hyper-v?

    2
    0 Votes
    2 Posts
    299 Views
    mauzillaM
    @mauzilla nevermind google to the rescue
  • VM autostart

    4
    0 Votes
    4 Posts
    2k Views
    olivierlambertO
    Try to disable/enable autostart in Advanced section of your VM. That might do the trick.
  • Kudos for the XO User Interface

    2
    1 Votes
    2 Posts
    805 Views
    olivierlambertO
    Hello @geoffbland Thanks for the feedback To be fair, we added that precisely because our community/users asked for it! I wouldn't have thought of this by myself. That's the power of community, and for that, I thank you all!
  • "global name 'commmand' is not defined" while installing patches

    13
    0 Votes
    13 Posts
    4k Views
    julien-fJ
    @olivierlambert This error does not ring a bell to me.
  • Can't create second virtual disk for a VM using XOA

    3
    0 Votes
    3 Posts
    1k Views
    B
    @Andrew thank you , it's NFS mount yes. i perform forget and remount and now is ok, most probably i chose older storage from another host, the menu to select storage for VM showing everything associated with the pool and sometimes this is confusing. Thanks for your comment.
  • Permissions for users to be able to snapshot

    bugs done
    13
    0 Votes
    13 Posts
    5k Views
    olivierlambertO
    That's because doing a snapshot will have consequences on the SR. That's why we restricted the permissions for doing snapshot.
  • 0 Votes
    9 Posts
    3k Views
    olivierlambertO
    It's documented in the official documentation. https://xen-orchestra.com/docs/installation.html#updating