Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • Backup not showing

    6
    2
    0 Votes
    6 Posts
    838 Views
    F
    @olivierlambert said in Backup not showing: It's a public holiday today in France yes off course I forgot about it. I left too long ago to remember the dates lol
  • S3 backup failure after update

    Solved
    8
    0 Votes
    8 Posts
    953 Views
    olivierlambertO
    Thank you!
  • 0 Votes
    3 Posts
    1k Views
    olivierlambertO
    It's now fixed on master branch. Please be sure to get the latest commit, now it will work
  • Unable to create private network GRE/VxLAN

    1
    0 Votes
    1 Posts
    745 Views
    No one has replied
  • Error when starting VM after creation

    7
    0 Votes
    7 Posts
    2k Views
    B
    @Danp I can agree with that
  • Scheduled enabling/disabling remote backup file systems?

    5
    0 Votes
    5 Posts
    980 Views
    M
    Thanks for your help. It seems to me that xo-cli works quite well for my purposes.
  • cloudinit

    7
    0 Votes
    7 Posts
    1k Views
    colegatronC
    @olivierlambert you're amazing. Thank you a lot!!
  • undefined defaultSettings

    3
    0 Votes
    3 Posts
    311 Views
    olivierlambertO
    Thanks for your feedback @Andrew !
  • Include network name in Create Network

    3
    2
    0 Votes
    3 Posts
    572 Views
    ForzaF
    @olivierlambert Yea, I have bonded networks. I do rename them so that I know what they are for. It seems that the bond number (bond 1 and bond 0) changes on different servers, as I asked about before, so the name and description is needed here to make it easier.
  • XO + cloud-init appending 0 to hostname

    9
    0 Votes
    9 Posts
    2k Views
    fohdeeshaF
    @pdonias yep I can confirm that works as expected, cloud-init uses the base VM name specified in the top of the create VM page, not the numbered VM names that result after creation. Nevermind!
  • Netbox plugin: VM's IP not in Netbox

    6
    0 Votes
    6 Posts
    2k Views
    pdoniasP
    Hi @RaHu! No, at the moment, we don't synchronize hosts' information. I'm not even sure where that information could go as there isn't such a thing as a host object in Netbox, AFAIK.
  • Orange exclamation mark without errors

    17
    2
    0 Votes
    17 Posts
    4k Views
    burbilogB
    @olivierlambert No, it does not. Still, sometimes badge with patches blink... funny.
  • xoce INTERNAL_ERROR while trying to create VM

    37
    0 Votes
    37 Posts
    20k Views
    olivierlambertO
    VIM
  • Setting Default Filters

    5
    0 Votes
    5 Posts
    2k Views
    G
    @olivierlambert Thanks - request raised. Next UI will be FAR more easier to manage those things
  • OVA Import Never Finishes

    14
    0 Votes
    14 Posts
    5k Views
    planedropP
    @Andrew Wanted to go ahead and add that it didn't seem slow to me to do the export, it was only 2GB, but still. It did take a bit to ramp up speed though, I got 4.5KB downloaded and then it sat there for a few minutes, but once it started downloading more data it sped up and the whole 2GB download was done in like 1-2 minutes, not crazy fast but not super slow either. I will try and test this with a bigger VM when I get the chance to see how it behaves.
  • XOA From The Sources Update Help

    9
    0 Votes
    9 Posts
    7k Views
    planedropP
    @olivierlambert Well, you were right, I was totally in the wrong folder without realizing it. However, after the rebuild it now won't start at all. Rebuilding the VM and restoring config is easy though (thanks to XO being so easy to use) so I might just do that to avoid confusion as this VM has some other issues unrelated to XO anyway.
  • xo-cli vm.migrate mapVifsNetworks object syntax

    3
    0 Votes
    3 Posts
    672 Views
    olivierlambertO
    @julien-f I think someone should update the doc with a real example
  • Xen Orchestra Quick Deploy Fails

    5
    1
    0 Votes
    5 Posts
    3k Views
    P
    @Danp Good catch, can't believe I missed that. Unfortunately, that produced a new error; Error code: SR_BACKEND_FAILURE_77 Error parameters: , Logical Volume group creation failed, From some googling around it appears the issue is that the disks still have a zfs_member tag on them. lsblk -f produces this: NAME FSTYPE LABEL UUID MOUNTPOINT sdd zfs_memb ├─sdd2 zfs_memb data 305869021769108511 └─sdd1 zfs_memb sdb linux_ra localhost:127 1d7d1927-dfdb-c8a8-4af1-b25c2b355a7a └─md127 zfs_memb boot-pool 17799519329276801846 ├─md127p5 ext3 logs-efkbam 0deeb614-6788-45f9-92b7-0f6acc05da6d /var/log ├─md127p3 zfs_memb boot-pool 17799519329276801846 ├─md127p1 ext3 root-efkbam 62e0f462-29f8-4c2a-8df7-bed45c144a4a / ├─md127p6 swap swap-efkbam 26a6ce99-d4fd-43d1-8a27-79bddafb8707 [SWAP] ├─md127p4 vfat BOOT-EFKBAM 0B9B-C4C7 /boot/efi └─md127p2 sde zfs_memb ├─sde2 zfs_memb data 305869021769108511 └─sde1 zfs_memb sdc linux_ra localhost:127 1d7d1927-dfdb-c8a8-4af1-b25c2b355a7a └─md127 zfs_memb boot-pool 17799519329276801846 ├─md127p5 ext3 logs-efkbam 0deeb614-6788-45f9-92b7-0f6acc05da6d /var/log ├─md127p3 zfs_memb boot-pool 17799519329276801846 ├─md127p1 ext3 root-efkbam 62e0f462-29f8-4c2a-8df7-bed45c144a4a / ├─md127p6 swap swap-efkbam 26a6ce99-d4fd-43d1-8a27-79bddafb8707 [SWAP] ├─md127p4 vfat BOOT-EFKBAM 0B9B-C4C7 /boot/efi └─md127p2 sda └─sda1 So it appears my next step is sorting that out. Unfortunately the only way of clearing these tags that I've found so far seems to be wiping the drives completely and starting over? If so that's going to suck as I don't have physical access to the machine right now. If anyone has any suggestions for removing errant zfs_member tags (this machine previously hosted a TrueNAS install) without wiping the whole damn machine, I'd be eager to hear them. If not it'll have to wait until I'm back in the office I guess. Thank you again @Danp for your help.
  • xen orchestra installation failed

    22
    2
    0 Votes
    22 Posts
    14k Views
    olivierlambertO
    You need to set a default sr with this command: xe pool-param-set uuid=<pool-uuid> default-SR=<sr-uuid>
  • Can't move VM - operation failed

    2
    0 Votes
    2 Posts
    759 Views
    E
    Well, it seems like it works if I create a snapshot and create a new VM from the snapshot on the new server. Should be workable for my need.