Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • 0 Votes
    4 Posts
    1k Views
    B
    I think this is important. When the issue appears the replicated VM that auto-starts has the [IMPORTING] prefix as in the image below. [image: 130e1c45-ad28-4b6c-a4d7-202b552ab723-image.png]
  • XOCE Warning on build

    2
    0 Votes
    2 Posts
    431 Views
    olivierlambertO
    Question for you @florent
  • Constant refreshing of interface

    15
    1
    0 Votes
    15 Posts
    4k Views
    A
    @pdonias Hi, On Master, as of yesterday, I see this only when I am logged in using an IP address on the URL instead of the hostname. Either way it is SSL with trusted certificate. There are no console errors Browser is Microsoft Edge on Windows No difference in behaviour between incognito mode and normal. Yes I see all the VMs There is an improvement - now if I am creating a new VM only the selected network is reverting back to default when it refreshes, the other things like number of cores and ram is remaining when I set it, whereas previously these also were wiped back to default every 20 seconds or so. Thanks Alex
  • VDI_IO_ERROR(Device I/O errors) when you run scheduled backup

    66
    0 Votes
    66 Posts
    42k Views
    R
    @rauly94 Hello everyone. Anyone can help me on this issue. Now it started happening on 2 vm's instead of 1 vm. It is happening on the backup replication. Error: VDI_IO_ERROR(Device I/O errors)This is a XenServer/XCP-ng error Start: Jul 5, 2023, 09:03:18 AM End: Jul 5, 2023, 09:44:46 AM Duration: 41 minutes Error: VDI_IO_ERROR(Device I/O errors)This is a XenServer/XCP-ng error Start: Jul 5, 2023, 09:03:09 AM End: Jul 5, 2023, 09:45:12 AM Duration: 42 minutes Error: VDI_IO_ERROR(Device I/O errors)This is a XenServer/XCP-ng error Type: delta
  • Deleting all existing Backups

    4
    0 Votes
    4 Posts
    2k Views
    planedropP
    Yeah for doing a fresh start it's easiest to just nuke the backup directory you were using and start over, have done it before and it's quick and easy vs trying to manually remove them all within XOA.
  • Deleting orphaned backups

    4
    0 Votes
    4 Posts
    705 Views
    DanpD
    Not that I am aware of.
  • 0 Votes
    5 Posts
    2k Views
    A
    @ronivay, I resolved my problem with orchestra which did not want to make backup with NFS. Orchestra wrote errors like: Command failed with exit code 1: mount -o -t nfs 192.168.11.53:/backups/xo /run/xo-server/mounts/0e5e9511-8912-48d4-96ad-532979533332 mount: only root can use "--options" option In general, orchestra tried to use mount option "--options" but mount command rejected this option. When I mount my NFS-shares manually everything was ok - mount works, read-write too, umount also. I did simplest process. I removed at all "--options" from mount command. (As far as I understand, *BSD mount will not work without this option but my Ubuntu works). Background: xcp-ng server (centos 8.2) as NFS server ubuntu server 16.04 where orchestra is going to be placed Orchestra installed 10 days ago from sources according to https://xen-orchestra.com/docs/installation.html#from-the-sources I complete followed document before chapter "Installing dependencies". I made yarn Then, before "yarn build", I manually edited file: /opt/xen-orchestra/@xen-orchestra/fs/src/_mount.js at string 68 I replaced await this.#execa('mount', ['-o', options, '-t', type, device, realPath], { with await this.#execa('mount', ['-t', type, device, realPath], { I then proceeded to follow the instructions: yarn build a so on... Now "patched" orchestra fine makes any kind of backup with NFS. At least, I solved this problem. Yet another question appeared as backup works What kind of Backup should I use to make full copy which enough for restoring (Heaven forbid)? I tried simply "Backup". It SUCCESSFULLY (!) created several files with 56 kbytes (no giga, no mega but kilo). I suppose it abnormal. My VM has got 20 Gb of disk space and about one half is already used (ubuntu server, postgres etc). As far as I understand (https://xcp-ng.org/forum/topic/7034/backup-with-local-usb-hdd-attached-sr_operation_not_supported/5?_=1688120707451) my version of xcp-ng (8.2.1) does not support "Snapshots" with local disks. Now I copy imagine of my VM with cron as temporary option but may be there is some more correct backup option?
  • Snapshot failure

    12
    0 Votes
    12 Posts
    3k Views
    S
    @sumansaha Hello Team, The issue has resolved after applying xe-toolstack-restart. Thanks.
  • increase 24 hour timeout-limit on backup/copy

    Solved
    24
    0 Votes
    24 Posts
    11k Views
    florentF
    @sumansaha that is a good news yes, the replication go through the XO VM, the faster the link the better the performances
  • if ACL is not free?

    3
    0 Votes
    3 Posts
    914 Views
    K
    @AtaxyaNetwork Thanks
  • Debian 12 (Bookworm) default template

    3
    0 Votes
    3 Posts
    2k Views
    escape222E
    @olivierlambert Thanks
  • Hosts have disappeared from XO Web UI

    30
    0 Votes
    30 Posts
    15k Views
    D
    @julien-f @julien-f All I have done is let ronivay's script do the builds daily on schedule if there is a new commit on the master branch. His script has not changed. There have been no new patches to the hosts. I don't have an explanation.
  • clone linode to local

    1
    0 Votes
    1 Posts
    330 Views
    No one has replied
  • SR_SOURCE_SPACE_INSUFFICIENT

    Solved
    4
    0 Votes
    4 Posts
    1k Views
    olivierlambertO
    XO saved the day
  • Check User creation Date/time

    3
    0 Votes
    3 Posts
    972 Views
    N
    @Danp Yes but unfortunately before of this incident audit is disabled
  • Move VMs between SRs

    4
    0 Votes
    4 Posts
    2k Views
    olivierlambertO
    No problem! Did you manage to do what you need?
  • XOA does not reliably autostart

    Solved
    4
    0 Votes
    4 Posts
    2k Views
    B
    Toggling it back and forth seems to have worked, thanks.
  • OIDC not redirecting back to XO

    22
    0 Votes
    22 Posts
    6k Views
    julien-fJ
    The fix is now merged on master and will be part of the next release.
  • DR - Failback Scenario

    5
    0 Votes
    5 Posts
    1k Views
    H
    That's great, we'll be watching the space.
  • How to restore vm and xo metadata from backups?

    2
    0 Votes
    2 Posts
    3k Views
    GheppyG
    I don't have experience with something like this, but I can do a mini lab with something like this, to test the steps below . What would I do. 0. Do you have metadata backup for XCP-ng? If YES 1.1. I would reinstall the server from scratch, before make a backup with Clonezilla with the boot disk of XCP-ng ; 1.2. I would reconnect iSCSI, without formatting it - reinitialize, only reconnecting (to not delete the data on it); 1.3. I would restore the metadata; 1.4. The result should be all the info about the VM that was on XPC-ng, and hopefully it also attaches the iSCSI disks. If NO 2.2. I would reinstall the server from scratch, before make a backup with Clonezilla with the boot disk of XCP-ng; 2.2. I would reconnect iSCSI, without formatting it - reinitialize, only reconnecting (to not delete the data on it); 2.3. I would redone the VMs from scratch and start attaching the disks to identify which and to which VMs they were attached before; 2.4. The result should be functional VMs In principle, if you have the disks intact, the data is there, you just have to restore the VMs (RAM, CPU, attached the correct disks, etc.) This is the menu for XCP-ng metadata backup, Backup/New. [image: cf7e9ec4-0d85-4ab6-9a1a-1061cd40a685-image.png] [image: 129ea089-e38b-4cf6-aa04-f7b3020b23a3-image.png]