Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • XO 6: Console updates?

    3
    0 Votes
    3 Posts
    1k Views
    C
    @olivierlambert I am imagining something like esxi / vsphere where I think it's their guest tool does a resize on window size change. I think I've done it with tightvnc where it can autoscale AND it can auto resize as well. Based on looking protocols like nx, spice, and tigervnc support it as well. Understood for the copy paste, is it possible to have another button in current UI next to the copy that is paste (understanding the current UI IS changing). All this button would do is send the keystrokes to the VM either from the text in the console copy field or from the clipboard (I've fine with ctrl+v, the clipboard to the multiline window).
  • Unable to add host to pool

    2
    0 Votes
    2 Posts
    1k Views
    tjkreidlT
    @BradyS Probably this is due to incompatible BIOS settings, such as C states, turbo mode, etc. Run "xe host-cpu-info" on each host to compare the two host settings. Also, make sure the firmware and update levels are all the same as those can also affect the CPU masks.
  • Unable to migrate VM cross pool (duplicate_vm)

    2
    0 Votes
    2 Posts
    565 Views
    DanpD
    You may want to review this thread.
  • Need to install XOSAN pack?

    13
    0 Votes
    13 Posts
    5k Views
    olivierlambertO
    XOSAN is deprecated. Take a look at XOSTOR (there's a thread in this forum with a how to participate to the beta)
  • 0 Votes
    5 Posts
    2k Views
    vilhelmV
    @pdonias Yes, I was running a newer version than that but just to make sure I upgraded to 8068b83ffe58e6caed0cac5816ac2690479a9c41. Still the same problem, unfortunately. I'm not too sure if it matters, but there are VMs running in the pool that does not have an IP in a "smaller" /24 prefix. So if the prefixes 192.168.0.0/16 and 192.168.100.0/24 are in Netbox, there might be VMs using IPs other than the ones in the 192.168.100.0/24 prefix.
  • 0 Votes
    33 Posts
    21k Views
    pdoniasP
    @vilhelm That's fixed: https://github.com/vatesfr/xen-orchestra/pull/6328. Thanks again for the report
  • Unable to add a host to a pool

    9
    0 Votes
    9 Posts
    3k Views
    olivierlambertO
    Sadly, it's hard to know what happened without getting the errors you had (eg when you tell: "VM will not start" is very vague).
  • How can I see active (not cached/buffered) RAM usage?

    7
    0 Votes
    7 Posts
    2k Views
    tjkreidlT
    @jivanpal Right; I simply meant you could start using these to track from this point onward. Also other options, like Cacti, MRTG, etc.
  • Managing different locations from one XO?

    5
    0 Votes
    5 Posts
    2k Views
    P
    @olivierlambert said in Managing different locations from one XO?: The code is open source but you need to install it and configure it yourself (if you are using XO from Github) OK, that makes sense.
  • Backup fails but works (Expected values to be strictly equal)

    6
    0 Votes
    6 Posts
    767 Views
    florentF
    @Andrew it seems that the merge fails but the watcher still report progress ( which doesn't move) Can you see if there is an error before ?
  • Restore missing network to host

    1
    0 Votes
    1 Posts
    667 Views
    No one has replied
  • Making changes to running backup selection

    3
    0 Votes
    3 Posts
    515 Views
    julien-fJ
    @mauzilla The change will only apply at the next run, it will not impact any current run.
  • XCP-ng - mount.nfs: access denied by server while mounting

    Solved
    4
    0 Votes
    4 Posts
    2k Views
    olivierlambertO
    Thanks a lot!
  • NFS ISO: Cannot read property 'Export' of undefined

    Solved
    8
    0 Votes
    8 Posts
    2k Views
    N
    @olivierlambert said in NFS ISO: Cannot read property 'Export' of undefined: Let's consider this thread fixed by adding the correct NFS configuration on the server side and create a new one describing your issue.
  • Manually Mount A HD When Needed From XCP-ng?

    docking station mount hd
    3
    0 Votes
    3 Posts
    697 Views
    N
    @ravenet said in Manually Mount A HD When Needed From XCP-ng?: You can script mount and umount commands as part of jobs or as part of backup jobs.
  • balance-alb on XOA

    4
    0 Votes
    4 Posts
    967 Views
    olivierlambertO
    Yes
  • Risks of running a shared pool?

    8
    0 Votes
    8 Posts
    3k Views
    olivierlambertO
    You can't add a host into another pool until it's "blank". It's hard to "merge" two pools together. So first, migrate VMs to the destination, clean the host and THEN add it to the pool.
  • Technical requirements for XOA for backup.

    6
    0 Votes
    6 Posts
    2k Views
    olivierlambertO
    No need to update XCP-ng, we don't want to introduce a dedicated agent. It will rely on another mechanism. We'll publish about it before the end of this summer
  • XOA incorrect size in metadata

    3
    1
    1 Votes
    3 Posts
    902 Views
    gcooperG
    First off, thank you very much Vates for this fantastic project. I appreciate it greatly. This is happening to us too after the last (CE) update. Buggin' me bad... G
  • XO 5.72 Storage Maintenance

    6
    0 Votes
    6 Posts
    2k Views
    J
    @geoffbland Hi, thanks for the reply... That's what I wound up doing, installing XO from source on a Raspberry PI that I had. I used it to restore my XO image from backup, once I did that I had to restore all of my guests (12 of them total). I could never figure out how to get my SR out of maintenance mode, so I wound up creating a new SR and restored each backup to the new SR. All back to normal after restoring the backup. Thank god XO backup works so well! I learned the hard way that I need to move my XO disks to local storage before I enter maintenance mode for my iSCSI SR... Oh well, lesson learned!