Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • Plugin Web-Hooks avec Mattermost

    7
    0 Votes
    7 Posts
    2k Views
    olivierlambertO
    You would have to write a daemon, listing for webhooks, parse it, and then send it to Mattermost with the expected payload.
  • Installing patches in pool fails (fixed)

    Solved
    5
    1
    0 Votes
    5 Posts
    2k Views
    K
    Not that you actually needed this reply, but confirmed patch works after upgrade this morning. Thanks for update and the patch.
  • Can't re-add deleted host

    10
    0 Votes
    10 Posts
    2k Views
    olivierlambertO
    I would suggest to NOT expose the host directly on the outside. Especially such an old version with a lot of security issues.
  • April 2022 XCP-ng Update Not Asking for Reboot

    3
    0 Votes
    3 Posts
    654 Views
    planedropP
    @olivierlambert My bad it's late and I totally forgot to check the github. Thanks!
  • Migrating from Intel -> AMD

    11
    0 Votes
    11 Posts
    4k Views
    J
    @olivierlambert said in Migrating from Intel -> AMD: I don't know, but what I can tell is the fact I myself migration my own production from Intel to AMD without any issue, so I really wonder why your guest can't boot Well it's weird... because happens with all Ubuntu 16 hosts too. For this Debian in particular, even after upgrading to bullseye, still won't boot on any AMD host, only on Intel ones. Finally I just reinstalled from scratch on an AMD host and migrated the data.
  • info Xen Orchestra cli cmd

    13
    1
    0 Votes
    13 Posts
    6k Views
    GheppyG
    Thanks for the guidance, that's all I need. It's all working now. Thank you
  • Hub Template Debian 11 cloud init network configuration

    5
    0 Votes
    5 Posts
    8k Views
    fohdeeshaF
    @vmpr Great work and example!
  • Cloud INIT Network and Hostname.

    13
    0 Votes
    13 Posts
    8k Views
    T
    @fohdeesha Yes i can confirm user error. I was uncommenting #network in the network side and it was causing issues with my whole config. I read this in another post on the forum. Thank you for your assistance. I really appreciate the time you provided.
  • This topic is deleted!

    2
    0 Votes
    2 Posts
    4 Views
    No one has replied
  • Starter Vs Standard Plan

    2
    0 Votes
    2 Posts
    2k Views
    olivierlambertO
    See for XOA pricing: https://xen-orchestra.com/#!/featuresmatrix If you want to use Xen Orchestra for your home lab, then go for the version from the sources: https://xen-orchestra.com/docs/installation.html#from-the-sources You'll have all the XO features but no pro support (which is OK for home lab)
  • Backup validation/verification

    2
    0 Votes
    2 Posts
    390 Views
    olivierlambertO
    Backup autorestore for basic tests is already planned and should be out this quarter @florent is the one working on it (he started to do some basic tests).
  • ZTP Restore XOA From Backup

    feature planned
    6
    0 Votes
    6 Posts
    3k Views
    M
    on my side importing backup config in a new XO installation worked (Using Webinterface). (i build from sources). Only thing wich bugs are backup jobs - i had to open and resubmit every backup job to get them work... br Mark
  • Increasing VM disk size breaks Continuous Replication backup

    12
    0 Votes
    12 Posts
    3k Views
    olivierlambertO
    I don't think we had time to investigate it sadly.
  • s3 remote error: Could not find API configuration s3-2006-03-01

    7
    0 Votes
    7 Posts
    2k Views
    M
    Ok so i created a symlink from @aws-sdk to was-sdk and now it works. as the error was looking for node_modules/aws-sdk and not node_modules/@aws-sdk
  • Transfer Configs between XOA'a

    config transfer
    9
    0 Votes
    9 Posts
    3k Views
    M
    @Aimdev eh man people use a lot of different browsers and don't always remember all the options, the dev's here are top 5 star really. I did it because I do use Safari and simply replicated the steps and noticed the pop-up warning (I never allow pop-ups by default) so I figured that could be the issue. Have a great weekend you too and you're welcome!
  • Error message in browser devtools console

    Unsolved
    1
    0 Votes
    1 Posts
    272 Views
    No one has replied
  • Changing XOA IP

    Solved
    3
    0 Votes
    3 Posts
    3k Views
    F
    @olivierlambert Thank you
  • Hub template request

    5
    0 Votes
    5 Posts
    2k Views
    fohdeeshaF
    @ITJamie Alma Linux 8.5 template is finished and should be added to the hub in the next day or two. I should have Rocky Linux done shortly after that. Note that in CentOS/RHEL related distros, the hostname: {name}% parameter that's filled in under the cloud-init config is not enough to change the hostname for the machine, CentOS (and related) expects a fully qualified domain name. To get the newly spawned VM have the hostname you'd like, supply fqdn parameter as well: use VM name as hostname: #cloud-config hostname: {name}% fqdn: {name}%.localdomain.local use custom hostname: #cloud-config hostname: testvm fqdn: testvm.localdomain.local
  • XOCE - export VM error

    7
    3
    0 Votes
    7 Posts
    1k Views
    julien-fJ
    Fixed, thanks for the report https://github.com/vatesfr/xen-orchestra/commit/7830c89e66e178921695aa5e17670717703ef290
  • XOA - fail to change pool master

    15
    0 Votes
    15 Posts
    5k Views
    R
    @stormi yes, that we be helpful indeed so we can stick to a build version at least for a while.