Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • app.createUserConnection is not a function

    12
    0 Votes
    12 Posts
    2k Views
    olivierlambertO
    I updated the doc accordingly: https://xen-orchestra.com/docs/community.html
  • Windows VM cannot boot, cannot insert ISO

    3
    0 Votes
    3 Posts
    2k Views
    A
    @mauzilla To boot an ISO in a VM, you need to select "DVD" in the boot order, put it first, and hit "Save". Then boot the VM. For ANY system (real or VM), you need boot it with the same type of bootstrap as it was installed to use. BIOS or UEFI. If you change the boot type then you have to make the OS ready to use the new/different settings (not just a VM problem). If you created a Windows image from a working system that booted with UEFI then you have to copy ALL partitions (the whole disk), not just the C windows drive.
  • Cannot resume an imported image

    3
    0 Votes
    3 Posts
    984 Views
    A
    @stormi Thanks for the big help that fixed the issue.
  • 0 Votes
    33 Posts
    19k Views
    Y
    Hi, first of all, thank you for developing and supporting these awesome products. I witnessed a similar issue upon running continuous replication on a VM after growing one of the disks on the source side. I run delta backup to a NFS share and continuous replication to another XCP-ng host in one job. The most important part of the relevant log messages remind me of this issue - this topic is the only similar reference I was able to find, so I hope this is the right place to post. If not, please let me know, and I'll create a new topic Mar 21 01:00:29 xcp-ng-2 xapi: [ info||8947241 INET :::80|Importing raw VDI R:3967654dad6b|vhd_tool_wrapper] Executing /bin/vhd-tool serve --source-format vhd --source-protocol none --source-fd 1f47b1fe-a9ea-4bda-ab8e-2101e5677059 --tar-filename-prefix --destination file:///dev/sm/backend/f7aca870-12e0-8352-9f86-f52d575eb313/6cd16448-6839-476d-93b1-2f8b816c827f --destination-format raw --progress --machine --direct --destination-size 0 --prezeroed Mar 21 01:00:29 xcp-ng-2 xapi: [error||8947241 INET :::80|Importing raw VDI R:3967654dad6b|vhd_tool_wrapper] vhd-tool failed, returning VDI_IO_ERROR Mar 21 01:00:29 xcp-ng-2 xapi: [error||8947241 INET :::80|Importing raw VDI R:3967654dad6b|vhd_tool_wrapper] vhd-tool output: vhd-tool: Non-zero size required (either a pre-existing destination file or specified via --destination-size on the command line)\x0A I'm currently running Xen Orchestra compiled from sources, on commit 5bc44363f9ac9fa534f3247e697f1b3c6991e916. XCP-ng is on version 8.2.0. I know that this is not fully up-to-date, but after retrying that backup as a first measure, Xen Orchestra ran a full backup for that VM, so I can't reproduce that issue anymore, but I figured posting that here might help resolving the aforementioned issue, if the causes correlate.
  • Netbox Plugin

    2
    0 Votes
    2 Posts
    909 Views
    olivierlambertO
    Hi @LTSFGriffin Netbox sync plugin is available in Enterprise tier
  • Transport-email and Google SMTP

    3
    0 Votes
    3 Posts
    2k Views
    J
    @Darkbeldin I wasn't sure about turning on two-factor. I went through that process and generated the "app password" and it seems to be working. Thanks for the info!
  • XOA can't start after installation and contradictory messages

    13
    0 Votes
    13 Posts
    6k Views
    olivierlambertO
    FYI, we modified the deploy script to be able to automatically modify XOA's VIF to run on the management network. So even in case of using only bonded networks like @Low351, this will now work.
  • Dashboard Health gives 'an error has occurred'

    10
    0 Votes
    10 Posts
    2k Views
    DanpD
    @davidg said in Dashboard Health gives 'an error has occurred': 5.58.1 That's ancient, so not a valid comparison. It's likely that a recent commit has broken something that they will eventually identify / fix.
  • New Smart Backup failure

    backup xenorchestra smart backups
    14
    0 Votes
    14 Posts
    4k Views
    mguyattM
    I did for sure. But I noticed that a new commit(886ff2cd7) was made literally in about the last hour and after updating again to that version all is good!
  • Server and VM report

    9
    0 Votes
    9 Posts
    3k Views
    J
    @olivierlambert We are using rrd2csv to get host cpu stats into SQL to provide nice Grafana page sorted by pool. It would be nice to dial even further down to the vm's that are running high cpu or have memory burden.
  • Kubernetes recipe failed - tasks stuck

    3
    0 Votes
    3 Posts
    741 Views
    P
    @BenjiReis XO from the appliance. I hadn't noticed the tasks queue counting up like that before I tried the recipe, but I'm perfectly willing to accept that I'm just not that observant. Thanks!
  • File recovery error

    4
    0 Votes
    4 Posts
    1k Views
    olivierlambertO
    Community version doesn't have a release number, but a commit version on master. Please check you are on the latest commit and rebuild
  • Xen Orchestra from Sources not showing host updates?

    4
    0 Votes
    4 Posts
    2k Views
    olivierlambertO
    That's correct. There's no more updates, that's why you MUST upgrade to 8.2 (see https://xcp-ng.org/docs/releases.html#all-releases )
  • XO HA - Different CPU's?

    2
    0 Votes
    2 Posts
    2k Views
    jedimarcusJ
    @wade_solarch Short answer: try to avoid that. Back in the old XenServer days, you had to manually change the cpu feature flags so it would work at all. https://xcp-ng.org/docs/requirements.html#pool-requirements This confirms that you can't mix Intel & AMD in a pool https://xcp-ng.org/docs/requirements.html#pool-requirements This explains Heterogeneous pools a little
  • Backup started to fail

    17
    3
    0 Votes
    17 Posts
    2k Views
    DarkbeldinD
    @stevewest15 Happy to help
  • 0 Votes
    1 Posts
    587 Views
    No one has replied
  • XOA - backups skipped to protect VDI chain

    23
    1
    0 Votes
    23 Posts
    8k Views
    olivierlambertO
    VDI to coalesce number should decrease over time yes. If it's not, you might have a coalesce issue in your storage, check the /var/log/SMlog in the relevant host (master for shared storage, the host attached to its local storage otherwise). Rescan will scan for the LV/VHD files. But coalesce is automatically checked/started every 5 minutes. Coalesce can take time (depending on SR read/write and quantity to "merge"). Next releases will have a visible task for pending coalesce (next major XCP-ng release). Until then, you can do a ps axf | grep coalesce to see if there's something happening.
  • CD drive not completely installed in XOA

    16
    0 Votes
    16 Posts
    8k Views
    julien-fJ
    @olivierlambert Done: https://github.com/vatesfr/xen-orchestra/commit/33b45d2eda2ce6d8071541da246bdcfd06b133b8 It's not perfect but that should help Example: vm.start { "id": "123e4f2b-498e-d0af-15ae-f835a1e9f59f", "bypassMacAddressesCheck": false, "force": false } { "errors": [ "R620-L3: VM_REQUIRES_SR(OpaqueRef:21fa00fc-62ce-4694-8b49-fcecd600a89e, OpaqueRef:4dd615a7-9a8c-4698-aceb-c10f782321c8)", "R620-L1: HOST_NOT_ENOUGH_FREE_MEMORY(216430280704, 18778341376)", "R620-L2: VM_REQUIRES_SR(OpaqueRef:21fa00fc-62ce-4694-8b49-fcecd600a89e, OpaqueRef:4dd615a7-9a8c-4698-aceb-c10f782321c8)" ], "message": "", "name": "Error", "stack": "Error: at Xapi._startVm (file:///home/julien/dev/vatesfr/xen-orchestra/packages/xo-server/src/xapi/index.mjs:1358:15) at Xapi.startVm (file:///home/julien/dev/vatesfr/xen-orchestra/packages/xo-server/src/xapi/index.mjs:1393:7) at Api.callApiMethod (file:///home/julien/dev/vatesfr/xen-orchestra/packages/xo-server/src/xo-mixins/api.mjs:307:20)" }
  • Enable Advanced Live Telemetry option disabled

    Solved
    3
    0 Votes
    3 Posts
    1k Views
    M
    @Danp K great, thanks.
  • Anti affinity on xoa

    7
    0 Votes
    7 Posts
    2k Views
    R
    @olivierlambert well, yes, there is definitely room for improvement on that part of the gui ;). although I was able to get any other plugin working no worries though, the quick fix is to remove the (optional)