Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    490 Topics
    4k Posts
    Z
    @poddingue said: Thanks for posting the fix. The same thing came up in an older thread, https://xcp-ng.org/forum/topic/9957, where disabling IPv6 also made xoa check go green. @HamiltonWDS explained a likely reason in https://xcp-ng.org/forum/post/87831: Node tries the addresses with a short timeout and can end up on the IPv6 one. Your curl -6 test helps a lot here, because it shows IPv6 doesn't connect at all on that network, so it's more than a slow path. Turning it off in XOA seems reasonable if you don't use IPv6 there; if you do, I'd guess the router side is where it really needs fixing, though I could be wrong (still haven't migrated to IPv6 myself ). Curious whether it sorts out the Cloud Backup too. XOA is using our management network where ipv6 is not needed and not enabled. Looks like our cloud backup finally ran for the first time in while too.[image: cloudbackup.jpg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    johnnezeroJ
    @pierrebrunet Thanks for the update. So is there any way to run the reclaimSpace function (i.e from the XO CLI or something, without having to build a whole REST API application or whatever that involves)?
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    52 Topics
    488 Posts
    CyrilleC
    New release ! Cloud Controller Manager v1.2.0 https://github.com/vatesfr/xenorchestra-cloud-controller-manager/releases/tag/v1.2.0 Adds a new cloud-node-out-of-service controller that applies the node.kubernetes.io/out-of-service=nodeshutdown:NoExecute taint to the nodes whose Xen Orchestra VM is halted or has been deleted. More about this feature in the documentation or #90
  • Backup & Snapshot Fail - SR_BACKEND_FAILURE_82

    5
    0 Votes
    5 Posts
    2k Views
    N
    Hi, 2 to 3 hours after the migration of VM to master coalesce disappeared. Thanks for help
  • Is it possible to reset to full backup at the desired time ?

    4
    4
    0 Votes
    4 Posts
    944 Views
    GheppyG
    Yes, that's what i want to do. But at the moment it create an snapshot for each cron that I made and I want to have only one snapshot and to be reset to full backup on Saturday. In essence, I want to have only one snapshot to an VM no matter how many cron I have attached to the replication. In this case, I want to reset the Continuous Replication chain when the server is least busy, not after a number of replications
  • Migration failing but not failing

    1
    1
    0 Votes
    1 Posts
    328 Views
    No one has replied
  • Plugin transport-email (v0.6.0) broken ?

    Solved
    20
    1 Votes
    20 Posts
    6k Views
    gskgerG
    @julien-f yes, works well (even with the 3td party script ). Nice job and fast as usual . Thanks @Alexander-0 for helping to pin it down
  • Transfer log missing

    2
    2
    0 Votes
    2 Posts
    313 Views
    olivierlambertO
    This is a known issue that will be fixed next week. @julien-f is working on it
  • From the sources build now requires >2GB ram

    4
    0 Votes
    4 Posts
    2k Views
    M
    I also encountered this problem. If you are using Debian you can use pre-packaged XO from sources https://github.com/mathiswolff/xen-orchestra
  • Error on Delta Backup - cannot read property "length" of undefined

    16
    0 Votes
    16 Posts
    3k Views
    julien-fJ
    @mbt Great! Thanks for your report and testing
  • Delta Backup job timeout does not get respected

    5
    0 Votes
    5 Posts
    1k Views
    mkrumbholzM
    @olivierlambert I tested this now a bit more. And now it works with the traffic limiter. Your last updates have optimised the backup system too much for my NFS storage and with that froze somehow the timeout (XO is running on local storage). And you are right it is doing it per VM, but i think this was in an older version the other way around (wich would be more important to me, but not for others ). But it would be great if i could get somehow an evenly distribution of the full backups .
  • Disaster Recovery Storage

    4
    0 Votes
    4 Posts
    2k Views
    olivierlambertO
    You need to get the exact same structure ideally to not lose any data. But it's not a big deal, just copy/rsync whatever you like to the destination and that's it.
  • Migrate failed

    24
    0 Votes
    24 Posts
    10k Views
    olivierlambertO
    Errors in CAPS means an error from the host. Check host logs, also check dynamic min memory == dynamic max
  • XO updating hosts queries

    4
    0 Votes
    4 Posts
    1k Views
    olivierlambertO
    Indeed, XO doc was built for XenServer (before XCP-ng existed). @Darkbeldin will update this accordingly
  • This topic is deleted!

    1
    0 Votes
    1 Posts
    24 Views
    No one has replied
  • XCP-NG static ip address issue

    2
    0 Votes
    2 Posts
    1k Views
    olivierlambertO
    Hi, I'm not sure to get what's your problem. What are you trying to achieve exactly? And what are you doing step by step?
  • XCP-ng 8.2 Rolling Update Error

    12
    0 Votes
    12 Posts
    2k Views
    C
    Great to hear, looking forward to the updates.
  • This topic is deleted!

    1
    0 Votes
    1 Posts
    15 Views
    No one has replied
  • XO Sources Build - Yarn ESOCKETTIMEDOUT ?

    Solved
    2
    0 Votes
    2 Posts
    2k Views
    DustyArmstrongD
    I fixed it by running the following: yarn cache clean yarn --network-timeout 10000000
  • xo-cli not working

    Solved
    4
    0 Votes
    4 Posts
    1k Views
    olivierlambertO
    Indeed.
  • Backing up of multiple VM's

    Solved
    3
    0 Votes
    3 Posts
    789 Views
    G
    @olivierlambert Oh, I totally missed the Advanced button! Thanks!
  • Pool Storage wont connect to 2nd host

    2
    2
    0 Votes
    2 Posts
    1k Views
    olivierlambertO
    Double check your 2nd host have permission to connect to the LUN. Try local commands on this host to see if you can access the LUN (iscsiadm for example).
  • Migrate all VMs bug - some VMs do not show as migrating.

    Solved
    6
    2
    0 Votes
    6 Posts
    811 Views
    olivierlambertO
    There's no XO tasks per se, so you can't see it What matters is you have all the VM migrated in the end, but yes, it's not "visible". Next major XO UI will have "XO tasks" that will display clearly the queue