Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    490 Topics
    4k Posts
    Z
    @poddingue said: Thanks for posting the fix. The same thing came up in an older thread, https://xcp-ng.org/forum/topic/9957, where disabling IPv6 also made xoa check go green. @HamiltonWDS explained a likely reason in https://xcp-ng.org/forum/post/87831: Node tries the addresses with a short timeout and can end up on the IPv6 one. Your curl -6 test helps a lot here, because it shows IPv6 doesn't connect at all on that network, so it's more than a slow path. Turning it off in XOA seems reasonable if you don't use IPv6 there; if you do, I'd guess the router side is where it really needs fixing, though I could be wrong (still haven't migrated to IPv6 myself ). Curious whether it sorts out the Cloud Backup too. XOA is using our management network where ipv6 is not needed and not enabled. Looks like our cloud backup finally ran for the first time in while too.[image: cloudbackup.jpg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    johnnezeroJ
    @pierrebrunet Thanks for the update. So is there any way to run the reclaimSpace function (i.e from the XO CLI or something, without having to build a whole REST API application or whatever that involves)?
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    52 Topics
    488 Posts
    CyrilleC
    New release ! Cloud Controller Manager v1.2.0 https://github.com/vatesfr/xenorchestra-cloud-controller-manager/releases/tag/v1.2.0 Adds a new cloud-node-out-of-service controller that applies the node.kubernetes.io/out-of-service=nodeshutdown:NoExecute taint to the nodes whose Xen Orchestra VM is halted or has been deleted. More about this feature in the documentation or #90
  • How to monitor if new XO release is available

    Solved
    8
    0 Votes
    8 Posts
    1k Views
    olivierlambertO
    The whole point to have users from the sources on master is to help us to find issues we might missed during the development (because it's a branch that's made to run, we only merge into it when we are OK with the new code to add after multiple code review). That's a kind of a moral contract if you are using it from the sources: you don't pay for anything despite having all XO features for free. In exchange, you can report issue or ask for new features while being able to see a fix fast because immediately after a fix is merged, it's available on master. If you want stability and no surprises at all (let's say to run XO in… production ) then XOA is the way to go
  • Restore from backup "iterable is not iterable"

    4
    0 Votes
    4 Posts
    979 Views
    olivierlambertO
    What do you mean by running an update? Did you git pull and rebuild?
  • Migrate button enhancements

    Solved
    3
    0 Votes
    3 Posts
    494 Views
    ForzaF
    @olivierlambert said in Migrate button enhancements: Hi! I think we fixed the migration issue in XOA latest. What version are you using? I'm running XOA 5.56.0 / latest channel. You are right. It is indeed fixed when doing migration from the VM list view: [image: 54ba8d18-bfe1-401d-983a-88f852edabac-image.png] But not from within the VM view: [image: 895c414d-1709-4a43-be95-316b038b05cd-image.png]
  • Password less connection to Host

    4
    0 Votes
    4 Posts
    1k Views
    olivierlambertO
    Our documentation can be modified by anyone via a pull request (see the link on the bottom of each page). If you want to write a guide on that, we'd be happy to accept your input!
  • Cache problem

    1
    0 Votes
    1 Posts
    495 Views
    No one has replied
  • Cannot find module bluebird

    5
    0 Votes
    5 Posts
    2k Views
    J
    @olivierlambert No problem, to be honest I'd forgotten that the script I was using was not the official script...
  • Can't add NFS Remote

    Solved
    6
    1
    0 Votes
    6 Posts
    4k Views
    R
    @olivierlambert Thanks! I did that and now it is just works. Thanks for the help!
  • 0 Votes
    5 Posts
    3k Views
    A
    I am using a Thinclient for my XCP Servers. Real small and cheap (if it is used) HP T620 with a 64G M2 SSD and 4 GRam Quadcore AMD CPU. To backup some VM i use a external USB3 HDD. It is running very nice and smoth. Power is between 5Watt an 20Watt excluding the USB Harddrive. My coutumer had mostly two Servers and a Thin client. my own Thinclient is used as a server for FHEM Homeautmatisation
  • Metadata Backup to Backblaze S3 compatible will not work

    5
    0 Votes
    5 Posts
    2k Views
    I
    Having the same issue here with metadata backups, tried Backblaze bucket and Amazon. Also the vm backups to S3 are failing usually with VDI_IO_ERROR(Device I/O errors) or "Error calling AWS.S3.upload: socket hang up" (but working to NAS). Is there somebody who made backups to S3 to work somehow?
  • Location of Backups?

    3
    0 Votes
    3 Posts
    1k Views
    capeschoolsC
    @olivierlambert Thanks!
  • 0 Votes
    5 Posts
    1k Views
    capeschoolsC
    @olivierlambert Okay no problem!
  • Move VM to a host containing a CR vm

    6
    0 Votes
    6 Posts
    2k Views
    DanpD
    @shorian No worries. I just figured the full error log would be beneficial to @olivierlambert and team if they review this thread. Edit: This thread seems related
  • Kuberenets cluster recipe not happy

    49
    0 Votes
    49 Posts
    35k Views
    olivierlambertO
    Thanks for the feedback @mathiashedberg !
  • New install some people can't login

    1
    0 Votes
    1 Posts
    602 Views
    No one has replied
  • New install can't add remote NFS

    Solved
    3
    0 Votes
    3 Posts
    1k Views
    M
    That was it you're awesome. You can mark it as solved.
  • XOCE Yarn Start Error code 1

    Solved
    13
    0 Votes
    13 Posts
    3k Views
    M
    Again thanks everyone. you can mark this as solved. The step I was missing was the config step. $ cd packages/xo-server $ mkdir -p ~/.config/xo-server $ cp sample.config.toml ~/.config/xo-server/config.toml
  • XO Installation on an offline system

    17
    0 Votes
    17 Posts
    6k Views
    L
    @olivierlambert Thanks
  • 0 Votes
    5 Posts
    1k Views
    pdoniasP
    @duxepu Ok, this is weird, I'm not able to reproduce that and I don't see how it's possible. Could you check a few things? from an admin point of view, at the bottom of the VM's advanced tab, please check that the user has Admin ACLs on the VM from the user's point of view, when you're on the snapshots tab, open the browser console (press F12 > Console tab) and check if there are any errors do you have this issue with all the users of all your Self Service groups or is it more specific? Thanks!
  • Bizarre Error during backup process (from the sources, 20.04)

    12
    0 Votes
    12 Posts
    3k Views
    DanpD
    Yesterday I updated to the latest sources and my backup ran successfully, so it appears that this issue is resolved. @carlosfrederico You'll need to switch back to the master branch before your normal update routine will work.
  • Debian cloud template for XenServer Default Password

    6
    0 Votes
    6 Posts
    5k Views
    olivierlambertO
    There's no root password. Use sudo -s