Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    490 Topics
    4k Posts
    Z
    @poddingue said: Thanks for posting the fix. The same thing came up in an older thread, https://xcp-ng.org/forum/topic/9957, where disabling IPv6 also made xoa check go green. @HamiltonWDS explained a likely reason in https://xcp-ng.org/forum/post/87831: Node tries the addresses with a short timeout and can end up on the IPv6 one. Your curl -6 test helps a lot here, because it shows IPv6 doesn't connect at all on that network, so it's more than a slow path. Turning it off in XOA seems reasonable if you don't use IPv6 there; if you do, I'd guess the router side is where it really needs fixing, though I could be wrong (still haven't migrated to IPv6 myself ). Curious whether it sorts out the Cloud Backup too. XOA is using our management network where ipv6 is not needed and not enabled. Looks like our cloud backup finally ran for the first time in while too.[image: cloudbackup.jpg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    johnnezeroJ
    @pierrebrunet Thanks for the update. So is there any way to run the reclaimSpace function (i.e from the XO CLI or something, without having to build a whole REST API application or whatever that involves)?
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    52 Topics
    488 Posts
    CyrilleC
    New release ! Cloud Controller Manager v1.2.0 https://github.com/vatesfr/xenorchestra-cloud-controller-manager/releases/tag/v1.2.0 Adds a new cloud-node-out-of-service controller that applies the node.kubernetes.io/out-of-service=nodeshutdown:NoExecute taint to the nodes whose Xen Orchestra VM is halted or has been deleted. More about this feature in the documentation or #90
  • getaddrinfo EAI_AGAIN error during backup

    7
    2
    0 Votes
    7 Posts
    3k Views
    ForzaF
    I got the same error again today. It's a delta job with two remotes. [image: fe12531c-52e2-4457-bc13-ee36db7f4fb5-image.png] Even though it says the backup failed, it looks like it is available on both remotes: [image: ca6eabb8-f810-44ac-bce0-7079755bc7de-image.png] srv01 = pool member srv02 = pool master srv03, srv04 = backup remotes XOA runs on srv02 The error seems to imply that it can't resolve the hostname of srv02, but that seems rather odd. I am using static IP only.
  • Error restoring VMs

    2
    0 Votes
    2 Posts
    498 Views
    olivierlambertO
    Hi, Please before creating a thread, read carefully this: https://xen-orchestra.com/docs/community.html Double check you are on the latest commit from master branch.
  • Pool CPU usage is impossible

    7
    2
    0 Votes
    7 Posts
    3k Views
    ForzaF
    @gigante said in Pool CPU usage is impossible: @s-pam I am unsure of the purpose of that, but at least now I know! Thanks! Just guessing here, but one reason is probably that single-threaded applications can only utilise one CPU thread, so they cannot go faster than 100%.
  • XO Community Edition Releases

    Solved
    3
    0 Votes
    3 Posts
    5k Views
    G
    @olivierlambert Thanks for the reply. I'll change to the "master" branch. I thought you were on a release schedule because you have a "releases" tab with the releases.
  • Delta Backup Failed invalid argument

    7
    0 Votes
    7 Posts
    2k Views
    julien-fJ
    @deoccultist Not much I can add there, it looks like a system error between your XOA and the remote. What kind of remote are you using? Does this happen often? Have you tried restarting xo-server or the OS?
  • Increasing the size of a disk

    Solved
    7
    1 Votes
    7 Posts
    24k Views
    H
    I can recommend gparted to resize your partions. It's easy and has a GUI. Important: you can't resize the boot partition without a live ISO.
  • Docker Support - CoreOS install woes

    Unsolved
    13
    0 Votes
    13 Posts
    5k Views
    olivierlambertO
    I don't think console is possible at all (I have no idea in fact, I don't think Docker got an API to allow a remote console display). XO could deal with Docker API, it's not a "physical" access in the container.
  • "Home" Menues...

    5
    0 Votes
    5 Posts
    1k Views
    C
    @olivierlambert Then keep it in mind for that.
  • XO created snapshots are too visible

    13
    0 Votes
    13 Posts
    5k Views
    J
    @olivierlambert So much for my memory..... XCP-ng center always exports a snapshot as a template. The menu item is called that and the xva files made always re-import as templates. The equivalent xe function is xe snapshot-export-to-template which does the same thing. The only way to export the snapshot as a VM is to set the is-a-template parameter to false then export with xe vm-export. Once that's been done it looks impossible to set is-a-template back to true. Using either xe vm-param-set or xe snapshot-param-set and trying to set is-a-template back to true gives an error "VM_IS_SNAPSHOT" I remember one of the backup scripts, NAUBackup/VMBackup if you're familiar with it, doing this and was never quite sure why until now. Looking through its code, it's creating a snapshot, setting is-a-template to false, exporting it as a VM, then deleting the snapshot in order to make an xva file backup while keeping the VM live. I'm not familiar with backups made by XO but I'm guessing you must be doing them in a similar fashion. Edit: I just did some more testing and discovered that as soon as I set the is-a-template parameter to false on a snapshot made by XCP-ng Center or xe vm-snapshot, it starts showing up in the xsconsole "All VMs" list and in xe vm-list commands just as snapshots created by XO do. In addition, they're showing up both on xe vm-list and xe snapshot-list. Fresh snapshots made with is-a-template still set to true show up in xe snapshot-list but do not show up in xe vm-list or xe template-list. They do show up in the list of templates available in XCP-ng Center when creating a new VM but those with is-a-template set to false do not. This is starting to smell to me more like a bug in xe or XAPI and possibly XCP-ng center as well but definitely in xe or XAPI. Is there any way to look into what's going on there?
  • Report plugin for downloading a CSV file of VMs

    2
    0 Votes
    2 Posts
    727 Views
    olivierlambertO
    Hi, The fastest way to get support for your XOA is by creating a ticket at https://support.vates.fr The forum is for community support.
  • Can't boot Windows 10 VM - Boots into UEFI Interactive Shell

    Solved
    6
    1
    0 Votes
    6 Posts
    16k Views
    D
    @runevn said in Can't boot Windows 10 VM - Boots into UEFI Interactive Shell: I found the solution. I had to press enter during the boot to boot into the "CD-ROM drive". Guuuuh. Thank you for coming back and posting this.
  • This topic is deleted!

    1
    0 Votes
    1 Posts
    1 Views
    No one has replied
  • XOA doesn't show Console over zerotier vpn

    2
    1
    0 Votes
    2 Posts
    2k Views
    olivierlambertO
    We do not encourage to modify the dom0 Console IP is returned by XAPI. So check your management network IP address.
  • Continous Replication - smart selection by source SR?

    3
    0 Votes
    3 Posts
    822 Views
    I
    @olivierlambert You are absolutely right: tags are enough. My fault. We will code some cronjobs that find the current SR, set the right tag and that's it. If the cronjob runs before the CR job is running, we should be fine. If you will implement the other idea: I guess (as you can specify only one backup target atm) an option to choose: 'store all vdis in target SR' or 'store only vdis from source SR in target SR' would be great, but if less work should be done: just store all vdis in the target SR - no matter where the source vdis are laying around Anyway: great work! Keep on!
  • cloud-config / cloud-init : standard variables / custom variables

    Unsolved
    2
    0 Votes
    2 Posts
    2k Views
    olivierlambertO
    The official Cloudinit documentation for example? https://cloudinit.readthedocs.io/en/latest/
  • 0 Votes
    2 Posts
    558 Views
    olivierlambertO
    Hi, We do not distribute XO via docker, so it's a 3rd party script/solution. Please report on the repo providing XO first, as explained in our doc: https://xen-orchestra.com/docs/community.html
  • VM migration - internal error

    3
    0 Votes
    3 Posts
    1k Views
    S
    @olivierlambert Ahhh, ok. Was focusing on XO; that's pointed me in the right direction. Thanks...and have a great weekend!
  • 0 Votes
    7 Posts
    2k Views
    bret_millerB
    @bret_miller said in Upgrade failed: Command failed: npm uninstall -g --silent xen-orchestra: npm version: 6.14.5 does not satisfies ^4.6 For the sake of someone after me with this problem, based on it apparently looking for npm version 4.6.x, I did this: sudo npm install -g npm@4.6.1 Then re-ran the xo check which came out clean except for being on and old version. Then re-ran the upgrade which immediately re-upgraded to npm 6.14.11 and completed the upgrade successfully. My theory then is that the upgrade to 6.14.x probably happened on a failed XO upgrade leaving the system in a state that I could no longer upgrade. It now appears fixed.
  • Reset SSH Password and/or Setup New XOA

    2
    0 Votes
    2 Posts
    2k Views
    olivierlambertO
    Open a support tunnel and we can change it for you Please open a support ticket
  • OVH fire

    5
    4 Votes
    5 Posts
    2k Views
    olivierlambertO
    No problem, we'll do that with a complete validation before publishing anything Let's continue our discussion in private then