XCP-ng
    • Categories
    • Recent
    • Tags
    • Popular
    • Users
    • Groups
    • Register
    • Login
    • Profile
    • Following 0
    • Followers 0
    • Topics 0
    • Posts 80
    • Groups 3
    P Offline
    1. Home
    2. pierrebrunet
    3. Posts

    Posts

    Recent Best Controversial
    • RE: Cleanup orphans backups

      @johnnezero You can use the docs directly in /rest/v0/docs. You just have to connect and fill in the uuid you need. It will work 🙂

      posted in Backup
      P
      pierrebrunet
    • RE: Cleanup orphans backups

      @johnnezero Hi,
      Sorry, it seems it is only in Rest API for now:
      You can check it here:

      <xoa-url>/rest/v0/docs/#/backup-repositories/ReclaimSpaceBackupRepository
      
      posted in Backup
      P
      pierrebrunet
    • RE: Cleanup orphans backups

      @johnnezero It just came out with the release... now 😄
      Just one thing, you may have empty directories even after the reclaimSpace task but they should be empty

      posted in Backup
      P
      pierrebrunet
    • RE: Cleanup orphans backups

      @henri9813 Hi,
      There should be a new "reclaimSpace" in next release which help you to clean repositories.

      Just to let you know, we prefer to not remove orphan backups in case a VM removal is accidental and you want to bring back it from a backup repository

      posted in Backup
      P
      pierrebrunet
    • RE: Error: Can't init vhd directory without using alias

      @Andrew This branch is now merged, thank you for your feedback!

      posted in Backup
      P
      pierrebrunet
    • RE: Master, commit a3139 failing backups

      @jr-m4 Hi,
      We have found this issue in another thread, it is now merged

      posted in Backup
      P
      pierrebrunet
    • RE: Error: Can't init vhd directory without using alias

      @manilx @andrew @abudef @robertblissitt
      Here is the branch we are working on: https://github.com/vatesfr/xen-orchestra/tree/fix_alias_vhd

      It should fix the issue, in case you have time to test it

      posted in Backup
      P
      pierrebrunet
    • RE: Error: Can't init vhd directory without using alias

      @Andrew Hi,
      I am on it, thank you for the report!

      posted in Backup
      P
      pierrebrunet
    • RE: Backup remote repository structure

      @abudef Hi,
      Do you think this doc can help you?

      Link to doc

      I think it needs some improvements, feel free to enhance it if you feel it is necessary!

      posted in Backup
      P
      pierrebrunet
    • RE: Backup fails with "Body Timeout Error", "all targets have failed, step: writer.run()"

      @JB @christopher-petzel Thanks for your patience! We are glad it works well!

      posted in Backup
      P
      pierrebrunet
    • RE: XOA 6.8 causes backup / replication failure

      @acebmxer Hi, I just checked your infra. It seems there was a connection error on the proxy around 2h ago: "Xen Orchestra Server could not be reached. Please check your connection."

      Can you retry a backup whenever it is possible for you?

      Edit: for this part, "error": "Having multiple authentication methods is not supported, please choose one"
      It is because you are connecting with two connections in parallel (one with a token and one basic).

      posted in Backup
      P
      pierrebrunet
    • RE: XOA 6.8 causes backup / replication failure

      @acebmxer @flakpyro Hi, there was a patch release this morning for a few issues. Can you update your XO and check if it still happen?

      posted in Backup
      P
      pierrebrunet
    • RE: Error mirroring full backups to backblaze b2

      @pedro_udifar Hi,
      Do you still have errors 500 when you are talking about general errors?

      posted in Backup
      P
      pierrebrunet
    • RE: Backup fails with "Body Timeout Error", "all targets have failed, step: writer.run()"

      @JB @majorp93 We made a smaller PR to be merged just after the release (because it is linked to almost all XAPI calls), the new branch is this one if you want to test: fix_undici_timeout
      Same fix, just a little smaller 🙂

      posted in Backup
      P
      pierrebrunet
    • RE: Feedback on immutability

      @gsszuber Hi,
      Yes indeed, you need to preserve the root of the bucket from Lifecycle. We just had a customer with a similar issue.
      Can you help us by giving a small screenshot of the field to filter out the root (or filter in the three folders) please?

      posted in Backup
      P
      pierrebrunet
    • RE: Backup fails with "Body Timeout Error", "all targets have failed, step: writer.run()"

      @bogikornel are you talking about another issue? We are on an issue specifically on "pool metadata backups". It seems you are talking about VM backups. If yes, can you send the backup log please?

      posted in Backup
      P
      pierrebrunet
    • RE: Backup fails with "Body Timeout Error", "all targets have failed, step: writer.run()"

      @acebmxer ok, too bad... I thought we had it...
      @majorp93 this can be a lead. I will ask xapi team if they changed something in pool metadata export.

      posted in Backup
      P
      pierrebrunet
    • RE: Backup fails with "Body Timeout Error", "all targets have failed, step: writer.run()"

      @MajorP93 Hi,
      Thank you, thank you! I think you found it! It seems to be SMB, @acebmxer can you confirm that you also use smb please?
      If this is the case, the bad news is I think we will need to update our docs to not advise SMB at all: it was already said for delta but maybe we will have to extend this to all kind of BR 😕

      posted in Backup
      P
      pierrebrunet
    • RE: Error mirroring full backups to backblaze b2

      @pedro_udifar Hi,
      You can try again with minPartSize=100000000 indeed. But I would advise you to contact B2 directly. They should have a clearer error to show instead of a 500.
      Thanks for your patience and your help

      posted in Backup
      P
      pierrebrunet
    • RE: Continuos replication failing with "checkBaseVdis() failed"

      @pedro_udifar This is indeed a particular case. Can you switch xo-server log to debug please? Then we would need the journalctl from your xo-server. You can give it to me through MP if you prefer.

      posted in Backup
      P
      pierrebrunet