Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • metadata backups suddenly failing

    Solved
    22
    1
    0 Votes
    22 Posts
    8k Views
    olivierlambertO
    Thank you @manilx and @Andrew for your feedback!
  • Backup of Linux VM with [nobak] disk failing health check (Solved)

    2
    1 Votes
    2 Posts
    733 Views
    olivierlambertO
    Ah thanks indeed a very interesting feedback! Thanks a lot
  • Rolling Pool Upgrade - Does not reboot hosts

    3
    0 Votes
    3 Posts
    881 Views
    K
    @olivierlambert There are lots of messages about: unable to parse XAPI datetime "2023-03-01T12:41:47.000Z" But nothing about the upgrade process. I was able to upgrade hosts 2+3 without any problem - but not automatically
  • vmware import failing

    2
    0 Votes
    2 Posts
    631 Views
    M
    @manilx I updated XO to the latest release (Updating Xen Orchestra from '63ee6b7f0' to '84e38505c') and tried again: Worked! BUT with this new release I have the following issue: https://xcp-ng.org/forum/topic/7020/metadata-backups-suddenly-failing
  • Backup timeout - hang or didn't work

    36
    2
    0 Votes
    36 Posts
    9k Views
    Tristis OrisT
    @olivierlambert to not create new topic, small continue here. timeout option still ignored. probably because of network problems i got backup error and job hangs every day. doesn't matter why it happens, but job will never get terminated by timeout. 21h job with 7h timeout. https://pastebin.com/U5HgKEzM just 1 Gb. [image: 1c80c5b5-248f-4506-a351-5bca47ee4f8c-image.png] [image: 7458ace9-3e08-4537-a7da-2d304033995e-image.png] i setup scheduled task to reboot xo once a day, to close this endless tasks.
  • Backup Error: 302 Found

    Solved
    20
    0 Votes
    20 Posts
    4k Views
    stucampS
    @julien-f @olivierlambert Heyo... good stuff guys. I have recompiled on latest and can happily confirm that the fix has resolved the issue!! Thanks!
  • Remote Backup needs internet to backup, local network. Static ips.

    3
    0 Votes
    3 Posts
    917 Views
    H
    @cookie-eater2000 make sure your Xen Orchestra also has a connection on the 10GB network (IP address on the xo vm)
  • warning on compile

    7
    0 Votes
    7 Posts
    2k Views
    DanpD
    @florent Thanks for the fix. P.S. @Gheppy was the original reporter.
  • VMGuest disk is missing in Xen Orchestra

    15
    1
    0 Votes
    15 Posts
    3k Views
    A
    @olivierlambert I do not understand wha t you mean by "You probably need to transform the disk in a "regular" and not snapshot". Not sure on how to do that, please provide the steps or if you have SOP ready, please point me to the SOP document.
  • XCP-ng latest - newly imaged CentOS Stream 8 hosts don't do kernel updates

    Unsolved
    3
    0 Votes
    3 Posts
    1k Views
    stormiS
    I don't see any obvious settting, and XCP-ng won't interfere with a guest OS installation, so the root cause for this missing GRUB_ENABLE_BLSCFG=true must be somewhere in the installation process, triggered by I-don't-know-what when being installed in an XCP-ng guest.
  • This topic is deleted!

    1
    0 Votes
    1 Posts
    23 Views
    No one has replied
  • NBD Backup not working

    23
    0 Votes
    23 Posts
    5k Views
    florentF
    @KLSsandman yes NBD is only used for delta backups
  • Backups never finish

    3
    0 Votes
    3 Posts
    1k Views
    julien-fJ
    @magicker If you are able to deploy an official XOA and reproduce the problem in it, I'll be able to investigate once you open a support tunnel: https://xen-orchestra.com/docs/xoa.html#support-tunnel
  • Managing HA-cluster in case of dead master

    2
    0 Votes
    2 Posts
    578 Views
    olivierlambertO
    Hi, The best practice is just to connect XOA to the master. You are thinking as if this situation will happen on regular basis, but it won't, and if it does you have a bigger problem than an XOA disconnection. If you have a backup job with email reporting, you'll be notified if XOA lost connection to the pool. There's nothing specific to do.
  • Scalability of XOA

    5
    0 Votes
    5 Posts
    1k Views
    J
    @Darkbeldin Parfait, merci ! I shall write to the Help email address!
  • Restoring Xen Orchestra from backup

    3
    0 Votes
    3 Posts
    1k Views
    A
    @olivierlambert Oh I see, thanks for the help.
  • First New Local Storage - "No VDIs in this storage"

    Solved
    6
    1
    0 Votes
    6 Posts
    2k Views
    olivierlambertO
    Yes, you need to get them flat in the folder, it doesn't crawl subfolders.
  • Website XOA XCP-NG missing

    2
    0 Votes
    2 Posts
    696 Views
    olivierlambertO
    Very likely indeed. We hope to recreate the XO website from scratch at some point, but it doesn't mean we'll let this slip Thanks a lot for the report, adding @Marc-pezin in the loop
  • Backing up the VM that is running Xen Orchestra

    Solved
    10
    0 Votes
    10 Posts
    3k Views
    olivierlambertO
    Ah the issue make sense now No worries about asking here, happy to see it works for you now
  • Backup warning: incorrect backup size

    7
    1
    0 Votes
    7 Posts
    674 Views
    M
    @julien-f Thx. I can safely ignore this then.....