Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • Is my backup configuration sane? (plus a bonus delta backup question)

    Solved
    16
    1
    0 Votes
    16 Posts
    4k Views
    olivierlambertO
    I'm talking about VM snapshots (and by transitivity, VDI snapshots). Retention is the number of backup you save on the backup repository, and it's totally unrelated to the number of snapshots when doing full or incremental backups.
  • Delta backups failing

    5
    0 Votes
    5 Posts
    1k Views
    A
    @Hannes_5253 No, my mistake.... I think it was this post. (off buy a digit... 8117 vs 8177)
  • If using XO from Source - How much ram are you assigning

    4
    1
    0 Votes
    4 Posts
    989 Views
    olivierlambertO
    Of real RAM usage? Eg with htop, take care of the cache too, because even if the cache is used doesn't mean it's really important. Maybe 8GiB is enough for example.
  • 0 Votes
    11 Posts
    5k Views
    olivierlambertO
    Nothing like that could happen. If your orphaned VDI is in use, it will error out with "VDI in use".
  • Just performed server update and stats page is blank in XO now.

    Solved
    6
    0 Votes
    6 Posts
    2k Views
    olivierlambertO
    You are welcome, thanks for the feedback
  • PIF_VLAN_STILL_EXISTS

    4
    1
    0 Votes
    4 Posts
    2k Views
    julien-fJ
    @olivierlambert I can do it pretty easily, but there may be a good reason for XAPI to throw this error instead.
  • NDB Connections per Disk?

    3
    0 Votes
    3 Posts
    1k Views
    planedropP
    I second 4 being a good sweet spot, I personally have seen very little improvement from going higher than 4 in my environments.
  • advanced tag creation

    Solved
    3
    0 Votes
    3 Posts
    1k Views
    V
    @ajpri1998 Thank you!
  • VDI_IO_ERROR Continuous Replication on clean install.

    Solved
    66
    2
    0 Votes
    66 Posts
    35k Views
    olivierlambertO
    Good to know it works now Thanks for the feedback!
  • Import from VMware fails after upgrade to XOA 5.91

    64
    0 Votes
    64 Posts
    35k Views
    olivierlambertO
    Great news and also great feedback! I think we'll add this in our guide
  • XOCE Warning on build

    Solved
    4
    0 Votes
    4 Posts
    1k Views
    GheppyG
    ok, thank you
  • Instant restore

    6
    0 Votes
    6 Posts
    1k Views
    olivierlambertO
    And I'd like to keep it like that It's very important!
  • Change "Created by" and "date" information

    Solved
    16
    1
    0 Votes
    16 Posts
    4k Views
    olivierlambertO
    No problem, happy to help!
  • XOA Recipe for Kubernetes cluster requiements?

    8
    1
    0 Votes
    8 Posts
    3k Views
    R
    @shinuza The version inside the Debian image and the version on GitHub may be different. It is likely that there will be more recent versions on GitHub. Just don't select a version and the latest version from the Debian repository will be installed. const k8sInstall = k8sVersion !== undefined ? `apt-get install -y kubelet=${k8sVersion} kubeadm=${k8sVersion} kubectl=${k8sVersion}` : "apt-get install -y kubelet kubeadm kubectl";
  • Pool local storage?

    Solved
    3
    0 Votes
    3 Posts
    1k Views
    D
    @olivierlambert Yes, I had just ejected and rejoined the host so I could reconfigure the network on the pool. Thanks for the information!
  • 0 Votes
    2 Posts
    704 Views
    olivierlambertO
    Do you have the XOA SDN controller enabled?
  • zen orshestra cummunity edit

    5
    0 Votes
    5 Posts
    1k Views
    jag5cofJ
    @DustinB thank you
  • Change Default Sort By

    3
    1
    0 Votes
    3 Posts
    631 Views
    pdoniasP
    @DustinB @olivierlambert I confirm it's not possible at the moment.
  • Migration failled

    Solved
    6
    0 Votes
    6 Posts
    1k Views
    RashidR
    @olivierlambert Thanks a lot. The Max vCPU was larger than the Physical CPU. Now it migrates successfully.
  • Missing Disks in VM

    15
    0 Votes
    15 Posts
    5k Views
    planedropP
    @Danp I agree with you here, but they also mentioned a "different newly created VM and attempted to install Windows 10 with two hard drives" and they only saw one disk, so was seeing if maybe the issue is related and there is something setup wrong. All disks should be visible to the Windows installer.