Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    poddingueP
    I tried this on my lab (with XO 6.9.1), moving the pool master to the other host with xe pool-designate-new-master and then back. XO stayed connected both times and picked up the new master, even though Settings > Servers still showed the old host's address; on the way back it took a minute or two to catch up. I didn't test 6.2.2, and I used the CLI rather than the XO 5 Advanced tab, so my guess that your older version is the difference is only a guess. For the XVA, I'm not aware of release notes for the appliance image itself: it updates itself after import, and the notes that exist are per XO version, in the monthly blog post and the changelog, both linked from https://docs.xen-orchestra.com/getting-started/releases#release-cadence-and-channels . How often the downloadable XVA gets rebuilt I don't know, so the 2025.12 tag may just be the date of the base image, but I'd rather ask than guess.
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    J
    Hi! We recieved a fix via the support after opening a ticket as suggested. Now the pool metadata backup is running smoothly again. As far as i know 6.9 will become "stable" after 6.10 is released. I'd still suggest a patch for the stable version, unless the new release is a few days. Best wishes Jacob
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • Backup - Bypass XOA

    2
    0 Votes
    2 Posts
    697 Views
    olivierlambertO
    That's because of XCP-ng/XenServer design. The host isn't pushing data, it's only exposing an HTTP handler to pull from it. You can use XO Proxies if you prefer: https://xen-orchestra.com/docs/proxy.html
  • Clear Filters by Default

    Solved
    3
    0 Votes
    3 Posts
    1k Views
    kdmK
    @darkbeldin Thank you. That was just off the bottom of the screen and I did scroll past it a few times, but being a little lonely icon, when all the other items have text, it didn't even register as a thing!
  • Multi step Jobs?

    feature in backlog
    7
    0 Votes
    7 Posts
    3k Views
    M
    @pdonias @olivierlambert hey thanks for adding this in latest release!! [image: 45658591-208e-46f6-b3af-74144019b94e-CleanShot 2021-07-02 at 19.36.01@2x.png]
  • VM Backup Folders

    Solved
    5
    0 Votes
    5 Posts
    1k Views
    JoeArnonJ
    @danp tnx
  • Backup on encrypted, exchangable disks

    2
    0 Votes
    2 Posts
    1k Views
    olivierlambertO
    Questions for @julien-f I suppose
  • Edit Storage host info after creation?

    Solved
    2
    1
    0 Votes
    2 Posts
    3k Views
    olivierlambertO
    Hi! That's is possible, you just need to shutdown all VMs using disks in there. Then, 4 steps: 0. Find the PBD currently connected to this SR via xe pbd-list Save the PBD information somewhere (xe pbd-param-list uuid=<PBD UUID> Unplug and remove the PBD (xe pbd-unplug and xe pbd-destroy Recreate the PBD by just changing the information using xe pbd-create In short, the PBD is like the "cable" between your host and your SR. Removing it won't remove any actual data, just the link between them. If you recreate it, and replug it, you'll find everything back
  • XCP-ng patches download URL

    3
    0 Votes
    3 Posts
    910 Views
    olivierlambertO
    It doesn't work like Citrix patches. Xen Orchestra will send a XAPI command to the host, that will in fact do a yum update command. The result is returned to XO and it will display available updates. We got a system using the best mirror for you: https://xcp-ng.org/docs/mirrors.html#original-mirror
  • XO tries to deactivate lvm volume group on yarn start

    Solved
    3
    1
    0 Votes
    3 Posts
    834 Views
    jamochlJ
    @olivierlambert cool, thanks
  • new backup shows loading... for ever

    6
    0 Votes
    6 Posts
    1k Views
    olivierlambertO
    Hi, Please open a support ticket, that would be easier to assist (you can also open a support tunnel so we can remotely access your XOA to investigate faster, see https://help.vates.fr/kb/en-us/9-xen-orchestra-appliance-xoa/16-create-a-support-tunnel ) edit: don't forget to go in XOA/Support then doing an XOA check, see https://help.vates.fr/kb/en-us/9-xen-orchestra-appliance-xoa/17-xoa-check
  • backup failed

    35
    0 Votes
    35 Posts
    17k Views
    julien-fJ
    @black_sam Thanks for your feedback
  • This topic is deleted!

    3
    0 Votes
    3 Posts
    138 Views
  • Change management network interface?

    8
    0 Votes
    8 Posts
    23k Views
    fohdeeshaF
    @station-already hehe glad you got it figured out Indeed, management interface changes are pretty "violent" in terms of how much they change and interrupt, so a reboot helps quite often - same for changing the virtual adapter/PIF assigned to a VM - alway a good idea to reboot the VM
  • Backup failed with message "HTTP request has been canceled"

    17
    1
    0 Votes
    17 Posts
    3k Views
    E
    @julien-f said in Backup failed with message "HTTP request has been canceled": node -p 'require.resolve("xen-api")' Hi all, I think the problem is fixed now. thanks for your help
  • backup failed with error writer is not defined

    Solved
    3
    0 Votes
    3 Posts
    752 Views
    R
    @danp after update, backup works fine, thanks
  • Remote Connection Failed.

    5
    0 Votes
    5 Posts
    3k Views
    olivierlambertO
    This means your NFS server doesn't support NFSv3.
  • Zen Orchestra lite

    6
    0 Votes
    6 Posts
    2k Views
    olivierlambertO
    This is not exposed in XAPI, so it might require to write a XAPI plugin.
  • Update script

    Solved
    7
    0 Votes
    7 Posts
    3k Views
    H
    @mrnaz look for the (first) error in your terminal where you execute the script to upgrade. Probably you need to upgrade the yarn or node version.
  • Multiple schedules == different backup sets?

    4
    0 Votes
    4 Posts
    810 Views
    ForzaF
    @mauzilla I've done so that I have two separate backup jobs incremental every 4 hours, with exception on weekends. Retention usually 8 days weekly full backups, zstd compression, every Sunday night. This way we have a separate backup from the incremental chain. We also are able to do more maintenance jobs on the nfs server etc during the off hours on the weekend.
  • Delta backup footer1 !== footer2 error

    Solved
    20
    0 Votes
    20 Posts
    5k Views
    A
    @mrnaz the fixed it in version 5.58.1. So update helped.
  • New Backup setup failures

    11
    1
    0 Votes
    11 Posts
    2k Views
    olivierlambertO
    No worries, just explained how hard it is to support uncontrolled environments Enjoy XO!