Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • XOCE shows "success" although backup not successful

    6
    0 Votes
    6 Posts
    860 Views
    olivierlambertO
    Is it a known behavior @julien-f ? To recap: with XVA backup starting the backup cancel the task get a success on the export I vaguely remember something about this
  • It is possible to create a vda VBD disk instead xvda?

    device vbd
    10
    0 Votes
    10 Posts
    3k Views
    olivierlambertO
    Great news then!
  • Adding Server to Pool Hangs/Fails

    4
    0 Votes
    4 Posts
    2k Views
    tjkreidlT
    @sgroel Curious. Are all the NICs the same on the existing pool hosts as well as the new host you add? Do all hosts have the same hotfix levels and the same overall hardware architecture? Seems odd as I ran servers this way for years. Maybe also look at the network switches to make sure they are all configured correctly. Finally, any clues in the /var/log files?
  • Full Backup Successful But In Kilobytes

    4
    0 Votes
    4 Posts
    1k Views
    D
    @Darkbeldin I checked the xensource.log on the server and found the error message "failed with exception Server_error(INVALID_DEVICE, [ autodetect ])" during export, similar to the post here: https://xcp-ng.org/forum/topic/4319/invalid_device-autodetect-during-backup I checked the XO dashboard health and found 256 "Pool Metadata Backup" VDIs attached to Control Domain. Not sure how or why the "Pool Metadata Backup" got stuck attached to Control Domain but I guess it has reached the 256 limit. I "Forget" all of them and full backup seems to be working now. For the record, it wasn't anything to do with snapshots. The VM was OFF so I guess it doesn't need to take a snapshot before transfer hence the log doesn't mention snapshot.
  • A lot of not found and error 127 in yarn build

    Solved
    17
    0 Votes
    17 Posts
    5k Views
    B
    @julien-f It works!!! No more error in the yarn build output. Thanks a lot!
  • Backups are deleted.

    9
    2
    0 Votes
    9 Posts
    2k Views
    V
    @olivierlambert Remote storage - hard drive in raid 5
  • Migrate xva image to hosted solution?

    1
    0 Votes
    1 Posts
    270 Views
    No one has replied
  • Warm migration - abort and monitor

    8
    0 Votes
    8 Posts
    1k Views
    olivierlambertO
    It's really hard to answer precisely in your case what's your bottleneck without spending more time doing a closer investigation on your setup
  • Attempting open source proxy (Resolved)

    6
    0 Votes
    6 Posts
    2k Views
    S
    @Andrew I got it working, thank you for your help. I just like to learn and test stuff out for fun, frequently unnecessarily, heh.
  • XO Lite (and XCP-NG 8.3 alpha)

    2
    0 Votes
    2 Posts
    806 Views
    olivierlambertO
    No telemetry, but if you have an issue with this alpha, please report it on the dedicated thread There's new graph and VM actions coming this month (if everything goes according to the plan)
  • This topic is deleted!

    2
    0 Votes
    2 Posts
    3 Views
  • Change default filter in VMs list from current "power_state:running"

    Solved
    7
    0 Votes
    7 Posts
    3k Views
    lawrencesystemsL
    @bullerwins It's a wonderful feature, you can have customized filters for VM, storage, Templates, and Pools. Combine that with using lots of tags and it makes larger deployments very manageable.
  • Error in the log at xo-cli –register

    6
    2
    0 Votes
    6 Posts
    851 Views
    olivierlambertO
    @denh I supposed you were reading this before posting: https://xen-orchestra.com/docs/community.html If you didn't, please do so Especially this section: https://xen-orchestra.com/docs/community.html#report-a-bug
  • XO License Costs

    3
    0 Votes
    3 Posts
    844 Views
    B
    @olivierlambert , Thank you. Someone from our team will reach out to you.
  • Backup VM - unused VHD

    16
    1
    0 Votes
    16 Posts
    4k Views
    olivierlambertO
    I think @florent did various modifications recently to handle those cases automatically.
  • Network pool + Cloud Init

    7
    0 Votes
    7 Posts
    1k Views
    B
    Cloud configs allow {{name}}% substitutions. From my perspective (as a user), for how {{name}} is used in my cloud configs something like {{address}} would be identical. What is the intended use case for the IPAM functionality in XOA if it can't be used like this? Real question, not trolling
  • Any updated tutorial on how to create new cloud images?

    22
    1 Votes
    22 Posts
    18k Views
    fohdeeshaF
    Also note the text at the top of your screenshot: to continue you need to select a boot device. There might be a way in that menu (or partition creation submenu) to mark that created partition as bootable, or maybe you just need to highlight/select the partition under "used devices" before hitting "done"
  • "an error has occurred" in disks tab for normal users

    Solved
    4
    3
    0 Votes
    4 Posts
    1k Views
    olivierlambertO
    You are welcome
  • Self service systems - how to build templates?

    9
    0 Votes
    9 Posts
    10k Views
    antoniolfdacruzA
    I would like some examples too. My latest (first) try gives me: alfcruz-adm@local.hcpa.ufrgs.br@volt-ampere:~/packer-plugin-xenserver$ packer build ./ubuntu-2004.pkr.hcl xenserver-iso.ubuntu-2004: output will be in this color. Build 'xenserver-iso.ubuntu-2004' errored after 8 seconds 155 milliseconds: API Error: SESSION_AUTHENTICATION_FAILED root Authentication failure ==> Wait completed after 8 seconds 155 milliseconds ==> Some builds didn't complete successfully and had errors: --> xenserver-iso.ubuntu-2004: API Error: SESSION_AUTHENTICATION_FAILED root Authentication failure ==> Builds finished but no artifacts were created. alfcruz-adm@local.hcpa.ufrgs.br@volt-ampere:~/packer-plugin-xenserver$ Using root user. This user/pass works over SSH.
  • can we use official ubuntu cloud images

    7
    0 Votes
    7 Posts
    2k Views
    R
    @encryptblockr hope to try the same with their even smaller "CORE" images. There is not an .OVA download but .xz downloads that when expanded have .img . https://cdimage.ubuntu.com/ubuntu-core/22/stable/current/ubuntu-core-22-amd64.img.xz and https://cdimage.ubuntu.com/ubuntu-core/22/stable/current/ubuntu-core-22-amd64+intel-iot.img.xz cloud-init seems to require experimentation and these small images boot quickly for me. Are you then following Fohdeesha's instructions?