Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • Remove/Reset TOTP 2FA

    mfa 2fa totp
    5
    0 Votes
    5 Posts
    2k Views
    DanpD
    Another option is to add a new admin user using xo-cli. Then login to XO as the new user and clear the OTP for the existing user.
  • Advanced Live Telemetry - Cluster-Wide

    2
    0 Votes
    2 Posts
    552 Views
    olivierlambertO
    Hi, No easily, no (at XCP-ng level at least). Maybe in the future with Open metrics everywhere. You can already track a VM metrics whatever they move to by having VM metrics from within the VM itself (eg VM is sending its metrics via netdata to a central netdata that will store them in Prometheus for example).
  • Boot after restore - excluded swap

    6
    0 Votes
    6 Posts
    934 Views
    olivierlambertO
    XO doesn't have access to the VM content so it's not possible at the moment.
  • Cannot use cloudConfig while creating VM with RPC call

    Solved
    23
    0 Votes
    23 Posts
    10k Views
    TheiLLeniumStudiosT
    @julien-f The problem seems to be fixed now! Thank you for the fix
  • Xen-Orchestra broken after rollback

    8
    0 Votes
    8 Posts
    3k Views
    M
    So I'm very very sorry for digging this up; I had this XO installation halted for a while wanted to come back to it. In the meanwhile the resolution for the error presented on the initial post: 2022-09-22T10:50:18.823Z xo:xo-server ERROR unhandled error event { error: Error: connect ECONNREFUSED ::1:6379 at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1161:16) at TCPConnectWrap.callbackTrampoline (node:internal/async_hooks:130:17) { errno: -111, code: 'ECONNREFUSED', syscall: 'connect', address: '::1', port: 6379 } } Solution: Edit /etc/redis.conf; Comment the bind directive; Save, restart redis, done.
  • Unable to convert VM to Template in Xen Orchestra ( VBD_IS_EMPTY )

    Solved
    11
    0 Votes
    11 Posts
    3k Views
    julien-fJ
    @josh383451 The bug was fixed 3 days ago: https://github.com/vatesfr/xen-orchestra/commit/73d88cc5f1a5458c68e6935a9d5a9240616007b1
  • Continuous Replication health check fails

    Solved
    7
    2
    0 Votes
    7 Posts
    2k Views
    bullerwinsB
    Just updated to lastest commit https://github.com/vatesfr/xen-orchestra/commit/4bd5b38aeb9d063e9666e3a174944cbbfcb92721 It's fixed now. Working wonderfully. Thanks! [image: 603fbea0-1c07-45b8-a005-54c100a74663-image.png]
  • Cannot export OVAs

    Solved
    64
    0 Votes
    64 Posts
    31k Views
    olivierlambertO
    Thanks for your feedback lads!
  • Option to Create Host only Private Network

    4
    1
    0 Votes
    4 Posts
    2k Views
    olivierlambertO
    Then it's a bug Pinging @pdonias or @julien-f
  • Import from vmware esxi 6.0 or 6.5

    13
    0 Votes
    13 Posts
    3k Views
    M
    @florent Tunnel ID sent via chat. Thank you for your help.
  • XOA Proxy Error when updating

    5
    1
    0 Votes
    5 Posts
    2k Views
    bullerwinsB
    @julien-f said in XOA Proxy Error when updating: @bullerwins XO Proxy Appliance deployment is not supported in XO built from sources. my bad, it used to work a few months back I believe @olivierlambert said in XOA Proxy Error when updating: I missed that in the original message, indeed FYI @bullerwins there's no such thing as XOA built from sources, you have either: XOA is Xen Orchestra virtual Appliance, that's the VM we distribute with pro support and QA/stable channel, updater and such XO from the sources is from Github, without pro support but community support, no QA no stable version, no udpater and such Thanks, I got confused with the naming, I'm using the second option. As a workaround I used a VPN to manage the remote XCP-ng host, thanks!
  • Kubernetes cluster recipes not seeing nodes

    43
    0 Votes
    43 Posts
    34k Views
    F
    @Raymondello you right, the issue is from the storage and I am looking into that. Thank you for sharing the UAT Testing, I didn't know about it
  • Fail2Ban for failed Xo-Web-Logins

    Solved
    16
    0 Votes
    16 Posts
    4k Views
    konsultanerK
    Found the issue. I used the service from the repo like this: But I had to replace @BINDIR@ to /usr/bin. [Unit] Description=Fail2Ban Service Documentation=man:fail2ban(1) After=network.target iptables.service firewalld.service ip6tables.service ipset.service nftables.service PartOf=iptables.service firewalld.service ip6tables.service ipset.service nftables.service [Service] Type=simple Environment="PYTHONNOUSERSITE=1" ExecStartPre=/bin/mkdir -p /run/fail2ban ExecStart=/usr/bin/fail2ban-server -xf start # if should be logged in systemd journal, use following line or set logtarget to sysout in fail2ban.local # ExecStart=/usr/bin/fail2ban-server -xf --logtarget=sysout start ExecStop=/usr/bin/fail2ban-client stop ExecReload=/usr/bin/fail2ban-client reload PIDFile=/run/fail2ban/fail2ban.pid Restart=on-failure RestartPreventExitStatus=0 255 [Install] WantedBy=multi-user.target
  • Unable to create NFS SR with truenas after rebuilding truenas

    Solved
    5
    1
    0 Votes
    5 Posts
    2k Views
    E
    @iLix That worked! I guess i forgot to enable NFSv4 after rebuilding it.
  • Samba Timeout - How to configure timeout limit / possible issues ?

    4
    0 Votes
    4 Posts
    5k Views
    olivierlambertO
    I can't follow what's done in 3rd party scripts, and it might be not trivial to find problems with them (if it's a problem due to the script or not). But before pointing any finger (I don't like that ) I would prefer to check with a fully up to date XOA on latest release channel and see if you have the same issue. At least, we'll be able to compare the behavior
  • 0 Votes
    2 Posts
    441 Views
    olivierlambertO
    Hi, I'm not aware of such feature on our side, you should ask AWS on how to import a XenServer/XCP-ng VM into EC2.
  • Non Fatal Error Starting XOA

    8
    0 Votes
    8 Posts
    2k Views
    olivierlambertO
    Quick note: XOA is for our Xen Orchestra virtual Appliance. You are using XO from the sources So it's just "XO". Anyway, indeed, it seems that your forever service isn't able to kill the process therefore, keep it.
  • Question On Cloud-init and ConfigDrive

    1
    0 Votes
    1 Posts
    1k Views
    No one has replied
  • Missing VMs from Restore

    5
    1
    0 Votes
    5 Posts
    1k Views
    yarozY
    @olivierlambert said in Missing VMs from Restore: Try to see after a new backup with this version We'll see then. Thank you. I'll check it after tonight's run.
  • Memory usage is not showing up in XOA

    Solved
    12
    1
    0 Votes
    12 Posts
    3k Views
    S
    @olivierlambert That did the trick. Wanted to make sure to say thanks for your help. Thanks again! Hope you have a great day!