Subcategories

  • VMs, hosts, pools, networks and all other usual management tasks.

    491 Topics
    4k Posts
    ForzaF
    @poddingue I'm using XOA 6.2.2. Unfortunately not able to update at the moment. Which reminds me of another thing. Where is there release information for the XOA XVA itself? When I login to my account, there is only the download button but no information on what version it is. [image: image.jpeg] I would like to know when a new version is published and a changelog for it. When I import the current XVA it is tagged with 2025.12 [image: image.jpeg]
  • ACLs, Self-service, Cloud-init, Load balancing...

    106 Topics
    870 Posts
    D
    I ran into the same problem with DR replicas. Ignoring VMs by tag would solve the problem, but so would excluding the ip address information.
  • All XO backup features: full and incremental, replication, mirrors...

    538 Topics
    6k Posts
    acebmxerA
    Latest commit fixed the synchronized snapshots showing up as a vm... Commit 8c2f3 [image: Screenshot_20261005_060854.png]
  • Everything related to Xen Orchestra's REST API

    88 Topics
    654 Posts
    poddingueP
    Pretty cool, @samuelolavo, thanks for clarifying!
  • Terraform, Packer or any tool to do IaC

    53 Topics
    492 Posts
    bvitnikB
    @bug-meister Ah. That's cloud-init's support for templating user-data. The issue is that with these templates you only have access to the info available inside the VM itself. No outside data can be used for templating unless it is somehow passed to the VM (inject a file, set xenstore values...)
  • Error: couldn't instantiate any remote

    33
    0 Votes
    33 Posts
    15k Views
    olivierlambertO
    Oh wow, you were lucky indeed! Happy to know you are safe
  • Restore fails with import_error

    9
    0 Votes
    9 Posts
    2k Views
    H
    @olivierlambert Thank you Olivier, posting it here can maybe help somebody else who does the same mistake
  • XO Backup Failing - Possibly to due Local Disks and loopback issues?

    7
    0 Votes
    7 Posts
    2k Views
    DanpD
    @MichaelCropper said in XO Backup Failing - Possibly to due Local Disks and loopback issues?: Job canceled to protect the VDI chain This usually indicates that there are VDIs that haven't coalesced. Check the "unhealthy VDIs" section of Dashboard > Health.
  • XO Remote mount.nfs: access denied by server while mounting

    26
    0 Votes
    26 Posts
    16k Views
    P
    @daninmanchester Thanks so much - this is the exact same problem I had, which was further complicated by running XO in Docker running on the OMV host exporting the NFS shares. So basically you just built a small XO VM instead of running it in Docker? I had originally been thinking of making a small VM to run XO in a container there - just because Docker containers are super easy to keep updated and I could run some other orchestration-y stuff there too, like Rancher - but if you're saying that's a non-starter I'll just bite the bullet and build a tiny VM dedicated to XO and be very grateful to you for having saved me a lot of frustration.
  • Wrong paths at pool's storage

    1
    1
    0 Votes
    1 Posts
    184 Views
    No one has replied
  • Remove xocloudconfig disk with xo-cli

    6
    0 Votes
    6 Posts
    2k Views
    olivierlambertO
    @slax we might get this upstream in few weeks
  • XO Contentious Replication no longer working (commit 3d3b6)

    4
    0 Votes
    4 Posts
    621 Views
    A
    Fixed on master (commit d8721). Thanks @florent !
  • VM, missing disk

    26
    4
    0 Votes
    26 Posts
    12k Views
    M
    @Danp Thanks, yes of course. I got excited about fixing my problems and reported too early Well, the VM has been working fine since the export / import. I can see both drives. Although the VM running fine, since the last post I had to address two related VDIs that had been connected to the Control Domain. One being million_D and the other million_D (with a camera icon). These probably ended up here because of a aborted / faulty snapshot or backup. I disconnected them .. checked a few things ... and then forgot them. Everything is running fine now. For future googlers: During the problem solving, I found out some pretty helpful info using tail -f /var/log/SMlog. To me, this issue is solved. Thank you all for the feedback.
  • S3 backup not retrying after error

    22
    0 Votes
    22 Posts
    5k Views
    A
    @florent No, I did not see that in the logs. I did see this problem is bigger than I thought. It happens more often than just causing a VM backup failure. It happens during the merge or other checks which causes the backup process to destroy (remove) parts of other VM backups. Clean VM directory parent VHD is missing parent VHD is missing parent VHD is missing some VHDs linked to the backup are missing some VHDs linked to the backup are missing some VHDs linked to the backup are missing some VHDs linked to the backup are missing and Clean VM directory VHD check error some VHDs linked to the backup are missing
  • This topic is deleted!

    1
    0 Votes
    1 Posts
    4 Views
    No one has replied
  • Great new feature: Restore file from S3 delta backup!

    Locked
    24
    2 Votes
    24 Posts
    10k Views
    olivierlambertO
    If I felt that way and we never had issues in the past, it's maybe for a reason. I'm a very patient person (as you can read since years here). So you shouldn't be saddened but more trying to understand something you provoked (it's still not clear that you understand it). I think it's important to know when not to push too far, and you were clearly too far Next time you are frustrated on an open source software you use for free (likely in production otherwise you wouldn't have been that frustrated), remember that being kind will be more productive in the end. This will be better for everyone. Also I hope it's more clear for you that using things on master was never meant to be under our internal QA since it's not a controlled environment (but it's documented with big warnings. Maybe I'll make it even more clear in the doc, I don't know, I'm surprised you didn't get it since you are using it since a while. Maybe this misunderstanding explained part of your frustration).
  • Coalesce not showing anymore

    Solved
    13
    2
    0 Votes
    13 Posts
    3k Views
    olivierlambertO
    Yay! Thanks both @Gheppy for the report and @errellion for the feedback
  • XCP-ng Authentication to AD (2019)

    6
    0 Votes
    6 Posts
    3k Views
    M
    @olivierlambert Thanks for the link , seems i will go the XOA route as suggested by @Darkbeldin
  • Networking disparity between guest OS and XO

    5
    4
    0 Votes
    5 Posts
    2k Views
    fohdeeshaF
    @jcdick1 I run opnsense on xcp-ng personally as well and use their packaged tools without issue, the only time I've gotten this behavior is when I hot-added interfaces and it changed the order of interfaces. If that's not it, I'm really not sure what would be causing this One last thing you can try in case it's a weird cash issue is (inside XOA) go to settings > servers, click the green connected button next to your xcp-ng server to disconnect it from xoa - then wait a couple seconds and click it again to reconnect it
  • Backup to shared storage

    7
    0 Votes
    7 Posts
    1k Views
    T
    @Darkbeldin In my network NFS and Samba shares would be a VM also on the same host so I would be in the same boat as before
  • Can't make new VM

    13
    0 Votes
    13 Posts
    4k Views
    olivierlambertO
    Same message than the other thread: https://xen-orchestra.com/docs/community.html Read this carefully.
  • Cannot import .ova Xen Orch from sources

    3
    0 Votes
    3 Posts
    748 Views
    olivierlambertO
    You should always start to read this before creating a new thread: https://xen-orchestra.com/docs/community.html
  • IP Address Configuration (does this exist in XOA?)

    2
    1
    0 Votes
    2 Posts
    4k Views
    M
    It is in the same place in XO. Network tab of the host. Change the Mode from None to Static (or DHCP). This should get you a pop up to enter the address, netmask, etc.
  • Very slow Backup speed when using "Continuous Replication" to NFS target

    Solved
    5
    0 Votes
    5 Posts
    2k Views
    0nelight0
    @Andrew Thanks! How to close this issue?
  • NUT Client in XOA

    2
    0 Votes
    2 Posts
    843 Views
    olivierlambertO
    You can call the feature from the API or the CLI